summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2020-12-12 20:57:21 -1000
committerPaul Spooren <mail@aparcar.org>2021-02-15 16:35:49 -1000
commit6dba010157f2ac6485bb3dee6a5ed4450fb09463 (patch)
tree57d4c96b67e9f7cf42d8c29e71c4e68bb60963ff /include
parent46b6ee7ffc457af8aad1a0f7e5936f50041141d8 (diff)
downloadopenwrt-6dba010157f2ac6485bb3dee6a5ed4450fb09463.tar.gz
openwrt-6dba010157f2ac6485bb3dee6a5ed4450fb09463.tar.bz2
openwrt-6dba010157f2ac6485bb3dee6a5ed4450fb09463.zip
build/prereq: require make 4.1 or later
FS#2086 "IS_TTY in the makefile is broken" reports flawed detection of stdout piping to a file. The issue describes how e.g. terminal color codes and up in log files if running make like `make > log.txt`. The proposed solution uses the make variable "MAKE_TERMOUT", which was introduced in make 4.1. All major distributions seem to updated to 4.1 or later, so this ideally dosen't break anything. Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'include')
-rw-r--r--include/prereq-build.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 6dce11cba2..f88e853b52 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -11,8 +11,8 @@ PKG_NAME:=Build dependency
# Required for the toolchain
$(eval $(call TestHostCommand,working-make, \
- Please install GNU make v3.82 or later. (This version has bugs), \
- $(MAKE) -v | grep -E 'Make (3\.8[2-9]|3\.9[0-9]|[4-9]\.)'))
+ Please install GNU make v4.1 or later., \
+ $(MAKE) -v | grep -E 'Make (4\.[1-9]|[5-9]\.)'))
$(eval $(call TestHostCommand,case-sensitive-fs, \
OpenWrt can only be built on a case-sensitive filesystem, \