summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2024-03-25 09:56:18 +0100
committerRobert Marko <robimarko@gmail.com>2024-04-06 11:24:18 +0200
commit706f0e395f5392da0a502f1039aa01ca14849ec5 (patch)
tree622294db41b87489f213ad28a1e23de678e24a9f /include
parentc922c780946ae522237f970991300cdcda20a3a7 (diff)
downloadopenwrt-706f0e395f5392da0a502f1039aa01ca14849ec5.tar.gz
openwrt-706f0e395f5392da0a502f1039aa01ca14849ec5.tar.bz2
openwrt-706f0e395f5392da0a502f1039aa01ca14849ec5.zip
include/download.mk: switch to zst compression
The compression is faster to (un)pack files, make use of it. Also add a new build prerequirement, the `zstd` to (un)pack files. Signed-off-by: Paul Spooren <mail@aparcar.org> [ improve commit title ] Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
Diffstat (limited to 'include')
-rw-r--r--include/download.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/download.mk b/include/download.mk
index ce8a7894b6..960dd816c0 100644
--- a/include/download.mk
+++ b/include/download.mk
@@ -13,7 +13,7 @@ ifdef PKG_SOURCE_VERSION
PKG_VERSION := $(if $(PKG_SOURCE_DATE),$(subst -,.,$(PKG_SOURCE_DATE)),0)~$(call version_abbrev,$(PKG_SOURCE_VERSION))
endif
PKG_SOURCE_SUBDIR ?= $(PKG_NAME)-$(PKG_VERSION)
- PKG_SOURCE ?= $(PKG_SOURCE_SUBDIR).tar.xz
+ PKG_SOURCE ?= $(PKG_SOURCE_SUBDIR).tar.zst
endif
DOWNLOAD_RDEP=$(STAMP_PREPARED) $(HOST_STAMP_PREPARED)