summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-03-14 03:17:06 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-03-14 03:17:06 +0000
commit72faa09dff0e69a6a1d4cbd0e0078573a242c817 (patch)
treebdbb327e505b6edf83ca1d991402895b4ac1a484 /include
parent494110052361221257ab37c2f19d3ab32a1608eb (diff)
downloadopenwrt-72faa09dff0e69a6a1d4cbd0e0078573a242c817.tar.gz
openwrt-72faa09dff0e69a6a1d4cbd0e0078573a242c817.tar.bz2
openwrt-72faa09dff0e69a6a1d4cbd0e0078573a242c817.zip
move cflags default setting to target makefiles
SVN-Revision: 14866
Diffstat (limited to 'include')
-rw-r--r--include/target.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/include/target.mk b/include/target.mk
index ace3db0ffd..5d8baeaeb6 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -150,6 +150,13 @@ ifeq ($(DUMP),1)
# remove duplicates
FEATURES:=$(sort $(FEATURES))
endif
+ DEFAULT_CFLAGS_i386=-O2 -pipe -march=i486 -funit-at-a-time
+ DEFAULT_CFLAGS_x86_64=-O2 -pipe -march=athlon64 -funit-at-a-time
+ DEFAULT_CFLAGS_mips=-Os -pipe -mips32 -mtune=mips32 -funit-at-a-time
+ DEFAULT_CFLAGS_mipsel=$(DEFAULT_CFLAGS_mips)
+ DEFAULT_CFLAGS_arm=-Os -pipe -march=armv5te -mtune=xscale -funit-at-a-time
+ DEFAULT_CFLAGS_armeb=$(DEFAULT_CFLAGS_arm)
+ DEFAULT_CFLAGS=$(if $(DEFAULT_CFLAGS_$(ARCH)),$(DEFAULT_CFLAGS_$(ARCH)),-Os -pipe -funit-at-a-time)
endif
define BuildTargets/DumpCurrent
@@ -163,6 +170,7 @@ define BuildTargets/DumpCurrent
echo 'Target-Arch: $(ARCH)'; \
echo 'Target-Features: $(FEATURES)'; \
echo 'Target-Depends: $(DEPENDS)'; \
+ echo 'Target-Optimization: $(if $(CFLAGS),$(CFLAGS),$(DEFAULT_CFLAGS))'; \
echo 'Linux-Version: $(LINUX_VERSION)'; \
echo 'Linux-Release: $(LINUX_RELEASE)'; \
echo 'Linux-Kernel-Arch: $(LINUX_KARCH)'; \