summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorDoug Kerr <dek3rr@gmail.com>2022-09-08 19:07:18 -0400
committerPetr Štetiar <ynezz@true.cz>2023-05-22 13:23:35 +0200
commit7d0fb2cc34cb7aaa2b6eaca4f14f2c20778d3e40 (patch)
tree7536439017e38b3e101ee563a9e609975945584d /include
parentbd262663142e90f64f1c256b3e6b2b979c1022c0 (diff)
downloadopenwrt-7d0fb2cc34cb7aaa2b6eaca4f14f2c20778d3e40.tar.gz
openwrt-7d0fb2cc34cb7aaa2b6eaca4f14f2c20778d3e40.tar.bz2
openwrt-7d0fb2cc34cb7aaa2b6eaca4f14f2c20778d3e40.zip
build: drop support for python 3.6
python 3.6 EOL was Dec. 2021 buildbot is running debian 10 which ships with 3.7 meson 0.62+ requires 3.7 Signed-off-by: Doug Kerr <dek3rr@gmail.com> Signed-off-by: Petr Štetiar <ynezz@true.cz> [rebased]
Diffstat (limited to 'include')
-rw-r--r--include/prereq-build.mk10
1 files changed, 4 insertions, 6 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 52988fbda9..9096e379bb 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -175,23 +175,21 @@ $(eval $(call SetupHostCommand,install,Please install GNU 'install', \
$(eval $(call SetupHostCommand,perl,Please install Perl 5.x, \
perl --version | grep "perl.*v5"))
-$(eval $(call SetupHostCommand,python,Please install Python >= 3.6, \
+$(eval $(call SetupHostCommand,python,Please install Python >= 3.7, \
python3.11 -V 2>&1 | grep 'Python 3', \
python3.10 -V 2>&1 | grep 'Python 3', \
python3.9 -V 2>&1 | grep 'Python 3', \
python3.8 -V 2>&1 | grep 'Python 3', \
python3.7 -V 2>&1 | grep 'Python 3', \
- python3.6 -V 2>&1 | grep 'Python 3', \
- python3 -V 2>&1 | grep -E 'Python 3\.([6-9]|[0-9][0-9])\.?'))
+ python3 -V 2>&1 | grep -E 'Python 3\.([7-9]|[0-9][0-9])\.?'))
-$(eval $(call SetupHostCommand,python3,Please install Python >= 3.6, \
+$(eval $(call SetupHostCommand,python3,Please install Python >= 3.7, \
python3.11 -V 2>&1 | grep 'Python 3', \
python3.10 -V 2>&1 | grep 'Python 3', \
python3.9 -V 2>&1 | grep 'Python 3', \
python3.8 -V 2>&1 | grep 'Python 3', \
python3.7 -V 2>&1 | grep 'Python 3', \
- python3.6 -V 2>&1 | grep 'Python 3', \
- python3 -V 2>&1 | grep -E 'Python 3\.([6-9]|[0-9][0-9])\.?'))
+ python3 -V 2>&1 | grep -E 'Python 3\.([7-9]|[0-9][0-9])\.?'))
$(eval $(call TestHostCommand,python3-distutils, \
Please install the Python3 distutils module, \