summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2021-02-15 23:09:53 +0100
committerFelix Fietkau <nbd@nbd.name>2021-02-15 23:11:44 +0100
commit7d6a636918bccf68b49324729759e7c569105f71 (patch)
tree63866a490d286438441a9331264942db8237e5c5 /include
parent1132340a22dad217e08918c0e403a4c9b63bf590 (diff)
downloadopenwrt-7d6a636918bccf68b49324729759e7c569105f71.tar.gz
openwrt-7d6a636918bccf68b49324729759e7c569105f71.tar.bz2
openwrt-7d6a636918bccf68b49324729759e7c569105f71.zip
build: fix getting ABI version for binary packages from the same source package
We can't rely on the .version file being created yet, so use package variables to get it Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include')
-rw-r--r--include/feeds.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/feeds.mk b/include/feeds.mk
index 5676cc4a8f..98e315bceb 100644
--- a/include/feeds.mk
+++ b/include/feeds.mk
@@ -43,5 +43,5 @@ endef
# 1: package name
define GetABISuffix
-$(if $(filter-out kmod-%,$(1)),$(foreach v,$(wildcard $(STAGING_DIR)/pkginfo/$(1).version),$(shell cat $(v))))
+$(if $(filter-out kmod-%,$(1)),$(if $(ABIV_$(1)),$(ABIV_$(1)),$(foreach v,$(wildcard $(STAGING_DIR)/pkginfo/$(1).version),$(shell cat $(v)))))
endef