summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2023-05-26 12:37:15 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2023-05-28 08:58:06 +0200
commitb14c6545df17a15fb0c8d3b916b24db51d088a87 (patch)
tree233ccabb849085c41be5578c05e0f1035a0177c3 /include
parent61ff33c1c282093f1d96ac2e5c106dedf7b897f7 (diff)
downloadopenwrt-b14c6545df17a15fb0c8d3b916b24db51d088a87.tar.gz
openwrt-b14c6545df17a15fb0c8d3b916b24db51d088a87.tar.bz2
openwrt-b14c6545df17a15fb0c8d3b916b24db51d088a87.zip
prereq-build: add missing check for Perl IPC::Cmd
OpenSSL fails to compile in Fedora 38 container due to the following: Can't locate IPC/Cmd.pm in @INC (you may need to install the IPC::Cmd module) (@INC contains: /openwrt/build_dir/target-x86_64_musl/openssl-3.0.8/util/perl /usr/local/lib64/perl5/5.36 /usr/local/share/perl5/5.36 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 /openwrt/build_dir/target-x86_64_musl/openssl-3.0.8/external/perl/Text-Template-1.56/lib) at /openwrt/build_dir/target-x86_64_musl/openssl-3.0.8/util/perl/OpenSSL/config.pm line 19. BEGIN failed--compilation aborted at /openwrt/build_dir/target-x86_64_musl/openssl-3.0.8/util/perl/OpenSSL/config.pm line 19. Compilation failed in require at ./Configure line 23. BEGIN failed--compilation aborted at ./Configure line 23. Seems like `dnf install -y perl-IPC-Cmd` fixes the issue. So lets fix it by checking for Perl IPC::Cmd host module availability. Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'include')
-rw-r--r--include/prereq-build.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 9096e379bb..5b63490ca3 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -94,6 +94,10 @@ $(eval $(call TestHostCommand,perl-thread-queue, \
Please install the Perl Thread::Queue module, \
perl -MThread::Queue -e 1))
+$(eval $(call TestHostCommand,perl-ipc-cmd, \
+ Please install the Perl IPC:Cmd module, \
+ perl -MIPC::Cmd -e 1))
+
$(eval $(call SetupHostCommand,tar,Please install GNU 'tar', \
gtar --version 2>&1 | grep GNU, \
gnutar --version 2>&1 | grep GNU, \