summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2024-02-20 21:14:03 +0000
committerDaniel Golle <daniel@makrotopia.org>2024-02-20 21:18:44 +0000
commitc42b915af0ea53bc1b65bc72afc9875da08b14d2 (patch)
tree654c3d1983e96c0b810a803548ff5aa2794404ab /include
parent1e93208bd2c605704b19fe8b04025c20c17e808d (diff)
downloadopenwrt-c42b915af0ea53bc1b65bc72afc9875da08b14d2.tar.gz
openwrt-c42b915af0ea53bc1b65bc72afc9875da08b14d2.tar.bz2
openwrt-c42b915af0ea53bc1b65bc72afc9875da08b14d2.zip
build: don't drop 'user' flag when using the ImageBuilder
Commit be9023ed43 ("build: fix opkg flags in rootfs") introduced a call to 'awk' which removes the 'user' flag from all installed packages in the opkg status file. While is is somehow desireable when building images directly within the buildroot, when using the ImageBuilder dropping the 'user' flag means loosing information about a package being deliberately selected or just implicitely pulled as a dependency. And that then break tools like 'auc' which request only packages having the 'user' flag from the asu server, resulting in broken images being delivered to users. Restore the original behavior in case of an image being created using the ImageBuilder. Fixes: be9023ed43 ("build: fix opkg flags in rootfs") Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'include')
-rw-r--r--include/rootfs.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/rootfs.mk b/include/rootfs.mk
index 2128aefc2a..b07f33d204 100644
--- a/include/rootfs.mk
+++ b/include/rootfs.mk
@@ -87,11 +87,11 @@ define prepare_rootfs
fi; \
done || true \
)
- awk -i inplace \
+ $(if $(IB),,awk -i inplace \
'/^Status:/ { \
if ($$3 == "user") { $$3 = "ok" } \
else { sub(/,\<user\>|\<user\>,/, "", $$3) } \
- }1' $(1)/usr/lib/opkg/status
+ }1' $(1)/usr/lib/opkg/status)
$(if $(SOURCE_DATE_EPOCH),sed -i "s/Installed-Time: .*/Installed-Time: $(SOURCE_DATE_EPOCH)/" $(1)/usr/lib/opkg/status)
@-find $(1) -name CVS -o -name .svn -o -name .git -o -name '.#*' | $(XARGS) rm -rf
rm -rf \