summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2024-02-21 13:13:34 -0800
committerPaul Spooren <mail@aparcar.org>2024-03-29 23:42:22 +0100
commitfcdc629144983cf5e3f5509e35149096aa2701b3 (patch)
tree5f64a97cd44647e3edc4921d7ee99de675ebf562 /include
parent4ae474afbd023a3386f4276ca8f948a44b49ff1b (diff)
downloadopenwrt-fcdc629144983cf5e3f5509e35149096aa2701b3.tar.gz
openwrt-fcdc629144983cf5e3f5509e35149096aa2701b3.tar.bz2
openwrt-fcdc629144983cf5e3f5509e35149096aa2701b3.zip
tools/meson: update to 1.3.2
Add explicit setup as implicit is deprecated. Rename pkgconfig as no hyphen is deprecated. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'include')
-rw-r--r--include/meson.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/meson.mk b/include/meson.mk
index 74c9d3dd7f..65716746fe 100644
--- a/include/meson.mk
+++ b/include/meson.mk
@@ -98,6 +98,7 @@ endef
define Host/Configure/Meson
$(call Meson/CreateNativeFile,$(HOST_BUILD_DIR)/openwrt-native.txt)
$(call Meson, \
+ setup \
--native-file $(HOST_BUILD_DIR)/openwrt-native.txt \
$(MESON_HOST_ARGS) \
$(MESON_HOST_BUILD_DIR) \
@@ -121,6 +122,7 @@ define Build/Configure/Meson
$(call Meson/CreateNativeFile,$(PKG_BUILD_DIR)/openwrt-native.txt)
$(call Meson/CreateCrossFile,$(PKG_BUILD_DIR)/openwrt-cross.txt)
$(call Meson, \
+ setup \
--buildtype plain \
--native-file $(PKG_BUILD_DIR)/openwrt-native.txt \
--cross-file $(PKG_BUILD_DIR)/openwrt-cross.txt \