summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2024-09-02 10:58:18 +0200
committerFelix Fietkau <nbd@nbd.name>2024-09-02 12:42:05 +0200
commitfd3d79862290197091678e9211ba071647756206 (patch)
treec35b511bd585c1fb532e598a69264632c2b4c50c /include
parent978aa43e5590e82535924521f4e3abbf555a4ed1 (diff)
downloadopenwrt-fd3d79862290197091678e9211ba071647756206.tar.gz
openwrt-fd3d79862290197091678e9211ba071647756206.tar.bz2
openwrt-fd3d79862290197091678e9211ba071647756206.zip
u-boot.mk: pass CROSS_COMPILE during config
Avoids running into unset architecture specific config symbols Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include')
-rw-r--r--include/u-boot.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/u-boot.mk b/include/u-boot.mk
index 454880989b..1bd7ed4bd5 100644
--- a/include/u-boot.mk
+++ b/include/u-boot.mk
@@ -110,10 +110,10 @@ define Build/U-Boot/Target
endef
define Build/Configure/U-Boot
- +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) $(UBOOT_CONFIGURE_VARS) $(UBOOT_CONFIG)_config
+ +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) CROSS_COMPILE=$(TARGET_CROSS) $(UBOOT_CONFIGURE_VARS) $(UBOOT_CONFIG)_config
$(if $(strip $(UBOOT_CUSTOMIZE_CONFIG)),
$(PKG_BUILD_DIR)/scripts/config --file $(PKG_BUILD_DIR)/.config $(UBOOT_CUSTOMIZE_CONFIG)
- +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) $(UBOOT_CONFIGURE_VARS) oldconfig)
+ +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) CROSS_COMPILE=$(TARGET_CROSS) $(UBOOT_CONFIGURE_VARS) oldconfig)
endef
ifndef UBOOT_USE_INTREE_DTC