summaryrefslogtreecommitdiffstats
path: root/package/base-files/Makefile
diff options
context:
space:
mode:
authorPhilip Prindeville <philipp@redfish-solutions.com>2023-09-13 09:10:32 -0600
committerHauke Mehrtens <hauke@hauke-m.de>2023-11-12 16:32:42 +0100
commit516a3176a671c4b8f344db39dbc0e003fbb841b8 (patch)
treed521c72bf0d71fbffa34004df5fa8aa2e9d7a82a /package/base-files/Makefile
parenta5ba28454b52024ca40ccf9ef3bde390bf9500c7 (diff)
downloadopenwrt-516a3176a671c4b8f344db39dbc0e003fbb841b8.tar.gz
openwrt-516a3176a671c4b8f344db39dbc0e003fbb841b8.tar.bz2
openwrt-516a3176a671c4b8f344db39dbc0e003fbb841b8.zip
base-files: Create /root w/ appropriate permissions
If /root is created with too permissive permissions, then sshd won't trust the contents of /root/.ssh as being adequately protected. Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
Diffstat (limited to 'package/base-files/Makefile')
-rw-r--r--package/base-files/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index bb369a82d9..67fc5d29c1 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -199,7 +199,8 @@ define Package/base-files/install
$(1)/usr/lib \
$(1)/usr/bin \
$(1)/sys \
- $(1)/www \
+ $(1)/www
+ mkdir -p -m 750 \
$(1)/root
$(LN) /proc/mounts $(1)/etc/mtab