summaryrefslogtreecommitdiffstats
path: root/package/base-files/Makefile
diff options
context:
space:
mode:
authorChristian Marangi <ansuelsmth@gmail.com>2024-05-26 19:30:32 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2024-06-11 23:58:18 +0200
commit8ca2e2852e1e9218720697c6014a99b5e1378585 (patch)
tree9ceef5efac26125794d8ac0ebfbc8d81db4f1557 /package/base-files/Makefile
parent9f6fc4f52423ef48a6a2d5f275dddc83996c2cfe (diff)
downloadopenwrt-8ca2e2852e1e9218720697c6014a99b5e1378585.tar.gz
openwrt-8ca2e2852e1e9218720697c6014a99b5e1378585.tar.bz2
openwrt-8ca2e2852e1e9218720697c6014a99b5e1378585.zip
base-files: skip fix-group-user uci-default for APK installation
For APK installation we don't have /usr/lib/opkg/info and user fixup are handled dirrectly. Skip the script in such case. Also remove this uci-defaults if we have CONFIG_USE_APK enabled. Link: https://github.com/openwrt/openwrt/pull/15543 Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
Diffstat (limited to 'package/base-files/Makefile')
-rw-r--r--package/base-files/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 4425bb346d..313bf377b4 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -249,6 +249,8 @@ ifneq ($(CONFIG_USE_APK),)
mkdir -p $(1)/etc/apk/
$(call FeedSourcesAppendAPK,$(1)/etc/apk/repositories)
$(VERSION_SED_SCRIPT) $(1)/etc/apk/repositories
+
+ rm -f $(1)/etc/uci-defaults/13_fix-group-user
else
$(if $(CONFIG_CLEAN_IPKG),, \
mkdir -p $(1)/etc/opkg; \