summaryrefslogtreecommitdiffstats
path: root/package/base-files/Makefile
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2024-05-22 16:19:45 +0200
committerDaniel Golle <daniel@makrotopia.org>2024-05-22 19:28:20 +0200
commit9a11bc3682dd7e95eb0534da9e2dbe3cdaa1c6de (patch)
tree730dee9285001fcee5e66c4b5ca27dcef1a1b49a /package/base-files/Makefile
parent4a78c46cbd64a69e0ce799d13a3c021260771b83 (diff)
downloadopenwrt-9a11bc3682dd7e95eb0534da9e2dbe3cdaa1c6de.tar.gz
openwrt-9a11bc3682dd7e95eb0534da9e2dbe3cdaa1c6de.tar.bz2
openwrt-9a11bc3682dd7e95eb0534da9e2dbe3cdaa1c6de.zip
build: generate private key for APK early
Other than OPKG which only uses signed package list, APK uses individually signed packages in addition to signed package lists. Hence, in order to be able to generate package, the private key needs to be generated before compiling packages. Express that dependency and generate the private key before building any packages instead of doing so as part of the base-files package build. Fixes: d788ab376f ("build: add APK package build capabilities") Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'package/base-files/Makefile')
-rw-r--r--package/base-files/Makefile6
1 files changed, 0 insertions, 6 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 0aa7ecd854..4425bb346d 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -117,12 +117,6 @@ endef
Build/Compile = $(Build/Compile/Default)
ifneq ($(CONFIG_USE_APK),)
- define Build/Configure
- [ -s $(BUILD_KEY_APK_SEC) -a -s $(BUILD_KEY_APK_PUB) ] || \
- $(STAGING_DIR_HOST)/bin/openssl ecparam -name prime256v1 -genkey -noout -out $(BUILD_KEY_APK_SEC); \
- $(STAGING_DIR_HOST)/bin/openssl ec -in $(BUILD_KEY_APK_SEC) -pubout > $(BUILD_KEY_APK_PUB)
- endef
-
ifndef CONFIG_BUILDBOT
define Package/base-files/install-key
mkdir -p $(1)/etc/apk/keys