summaryrefslogtreecommitdiffstats
path: root/package/boot/grub2/Makefile
diff options
context:
space:
mode:
authorTianling Shen <cnsztl@immortalwrt.org>2023-05-17 21:08:40 +0800
committerPaul Spooren <mail@aparcar.org>2023-05-18 11:35:29 +0200
commit48ed07bc0b94b930d369baf911014bedd5bf6a7e (patch)
treea9b4a50b621a0212b349e73140e8066cf94476d5 /package/boot/grub2/Makefile
parent3a6657540c3d6fc50a63caf8432e301e825ada16 (diff)
downloadopenwrt-48ed07bc0b94b930d369baf911014bedd5bf6a7e.tar.gz
openwrt-48ed07bc0b94b930d369baf911014bedd5bf6a7e.tar.bz2
openwrt-48ed07bc0b94b930d369baf911014bedd5bf6a7e.zip
treewide: replace AUTORELEASE with real PKG_RELEASE
Based on Paul Fertser <fercerpav@gmail.com>'s guidance: Change AUTORELEASE in rules.mk to: ``` AUTORELEASE = $(if $(DUMP),0,$(shell sed -i "s/\$$(AUTORELEASE)/$(call commitcount,1)/" $(CURDIR)/Makefile)) ``` then update all affected packages by: ``` for i in $(git grep -l PKG_RELEASE:=.*AUTORELEASE | sed 's^.*/\([^/]*\)/Makefile^\1^';); do make package/$i/clean done ``` Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
Diffstat (limited to 'package/boot/grub2/Makefile')
-rw-r--r--package/boot/grub2/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/boot/grub2/Makefile b/package/boot/grub2/Makefile
index 249acf1487..0613f46f99 100644
--- a/package/boot/grub2/Makefile
+++ b/package/boot/grub2/Makefile
@@ -7,7 +7,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=grub
PKG_VERSION:=2.06
-PKG_RELEASE:=$(AUTORELEASE)
+PKG_RELEASE:=5
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@GNU/grub