summaryrefslogtreecommitdiffstats
path: root/package/boot/grub2/Makefile
diff options
context:
space:
mode:
authorTomasz Maciej Nowak <tomek_n@o2.pl>2020-01-14 18:45:44 +0100
committerPetr Štetiar <ynezz@true.cz>2020-03-01 21:36:00 +0100
commitb322243d2f768a04a04831c45dabc627a41c4570 (patch)
tree162013f56e86a8d63c1e451d59682d3ef3991970 /package/boot/grub2/Makefile
parent48873ace4e4bca9cb5de05b7e0a229c221bece34 (diff)
downloadopenwrt-b322243d2f768a04a04831c45dabc627a41c4570.tar.gz
openwrt-b322243d2f768a04a04831c45dabc627a41c4570.tar.bz2
openwrt-b322243d2f768a04a04831c45dabc627a41c4570.zip
x86: add bootloader upgrade on sysupgrade
Currently bootloader always stays on the same version as when first written to boot medium (not true if partition layout changed, which will trigger sysupgrade process to write full disk image). That creates inconveniences as it always stays with same features or/and bugs. Users wishing to add support to additional modules or new version, would need to write the whole image, potentially destroying previous system configuration. To fix these, this commit adds additional routine to sysupgrade which upgrades unconditionally the bootloader to the latest state provided by OpenWrt. Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
Diffstat (limited to 'package/boot/grub2/Makefile')
-rw-r--r--package/boot/grub2/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/package/boot/grub2/Makefile b/package/boot/grub2/Makefile
index 1f92ba9250..b26ef64ca4 100644
--- a/package/boot/grub2/Makefile
+++ b/package/boot/grub2/Makefile
@@ -82,6 +82,11 @@ define Host/Configure
$(Host/Configure/Default)
endef
+define Package/grub2/install
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/grub-bios-setup $(1)/usr/sbin/
+endef
+
define Package/grub2-editenv/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/grub-editenv $(1)/usr/sbin/