summaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-at91
diff options
context:
space:
mode:
authorClaudiu Beznea <claudiu.beznea@microchip.com>2021-10-11 11:47:23 +0300
committerHauke Mehrtens <hauke@hauke-m.de>2021-10-24 18:52:17 +0200
commit8b7e577f76897ee44bc00a2303cbcae2a52b5ebf (patch)
tree8b3ad5c1d1f171d83dba5fd074582af844953149 /package/boot/uboot-at91
parent999c925f9d47637b3913229acb20568989df5ca3 (diff)
downloadopenwrt-8b7e577f76897ee44bc00a2303cbcae2a52b5ebf.tar.gz
openwrt-8b7e577f76897ee44bc00a2303cbcae2a52b5ebf.tar.bz2
openwrt-8b7e577f76897ee44bc00a2303cbcae2a52b5ebf.zip
at91: add support for sama5d2 icp board
Add support for SAMA5D2 ICP board. Hardware: - SoC: SAMA5D27 - RAM: 512 MB DDR3L - MMC: One stanard SD card interface - USB: One USB host switch 4 ports with power switch, One USB device type Micro-AB - CAN: 2 interfaces - Ethernet: One Gigabit Ethernet PHY through HSIC, One ETH switchport, One EtherCAT interface - WiFi/BT: Footprint for IEEE 802.11 b/g/n Wi-Fi plus Bluetooth module (Wi-Fi/BT), suitable for Microchip WILC3000-MR110CA or WILC3000-MR110UA - Debug port: One J-Link-OB/J-Link-CDC, one JTAG interface - Leds: one RGB LED - Buttons: reset, wakeup, 2 user buttons - Expansion: one PIOBU/PIO connector, 3 mikrobus sockets - Power mangament: PMIC (MCP16502), one power consumption device (PAC1934) Not working in Linux: - EtherCAT interface: there is no Linux support integrated - PAC1934: driver available at [1] but not integrated in Linux Flashing: - follow the procedure at [2] [1] https://ww1.microchip.com/downloads/en/DeviceDoc/pac193x_linux_driver.zip [2] https://www.linux4sam.org/bin/view/Linux4SAM/Sama5d2IcpMainPage#Create_a_SD_card_with_the_demo Signed-off-by: Claudiu Beznea <claudiu.beznea@microchip.com>
Diffstat (limited to 'package/boot/uboot-at91')
-rw-r--r--package/boot/uboot-at91/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/boot/uboot-at91/Makefile b/package/boot/uboot-at91/Makefile
index 06cfcd9045..822d71f796 100644
--- a/package/boot/uboot-at91/Makefile
+++ b/package/boot/uboot-at91/Makefile
@@ -59,6 +59,12 @@ define U-Boot/sama5d3_xplained_mmc
BUILD_DEVICES:=microchip_sama5d3-xplained
endef
+define U-Boot/sama5d2_icp_mmc
+ NAME:=SAMA5D2 ICP board (SDCard)
+ BUILD_SUBTARGET:=sama5
+ BUILD_DEVICES:=microchip_sama5d2-icp
+endef
+
define U-Boot/sama5d2_xplained_spiflash
NAME:=SAMA5D2 Xplained board (SPI Flash)
BUILD_SUBTARGET:=sama5
@@ -119,6 +125,7 @@ UBOOT_TARGETS := \
at91sam9x5ek_mmc \
sama5d3_xplained_nandflash \
sama5d3_xplained_mmc \
+ sama5d2_icp_mmc \
sama5d2_xplained_mmc \
sama5d2_xplained_spiflash \
sama5d4_xplained_mmc \