summaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-at91
diff options
context:
space:
mode:
authorSandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>2017-09-13 11:51:20 -0700
committerJohn Crispin <john@phrozen.org>2017-09-20 09:01:24 +0200
commit8f1764b98a2251c5780455ac131b38ecf9a53bca (patch)
tree4aa902910e3147a697243fda96415d2e0e9dfb87 /package/boot/uboot-at91
parent71a93a22fdd52b363ec3ec8b59a68ceeb1c6beff (diff)
downloadopenwrt-8f1764b98a2251c5780455ac131b38ecf9a53bca.tar.gz
openwrt-8f1764b98a2251c5780455ac131b38ecf9a53bca.tar.bz2
openwrt-8f1764b98a2251c5780455ac131b38ecf9a53bca.zip
uboot-at91: Add support for SAMA5D3 Xplained board
Add support for SAMA5D3 Xplained board and options to select & build u-boot configs for different media storage. Signed-off-by: Sandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>
Diffstat (limited to 'package/boot/uboot-at91')
-rw-r--r--package/boot/uboot-at91/Makefile16
1 files changed, 15 insertions, 1 deletions
diff --git a/package/boot/uboot-at91/Makefile b/package/boot/uboot-at91/Makefile
index 68e4ba498b..2c95377b0f 100644
--- a/package/boot/uboot-at91/Makefile
+++ b/package/boot/uboot-at91/Makefile
@@ -30,9 +30,23 @@ define U-Boot/at91sam9x5ek_nandflash
BUILD_SUBTARGET:=legacy
endef
+define uboot/sama5d3_xplained_nandflash
+ TITLE:=U-Boot for the SAMA5D3 Xplained board (NandFlash)
+ BUILD_SUBTARGET:=sama5
+ BUILD_DEVICES:=at91-sama5d3_xplained
+endef
+
+define uboot/sama5d3_xplained_mmc
+ TITLE:=U-Boot for the SAMA5D3 Xplained board (SDcard)
+ BUILD_SUBTARGET:=sama5
+ BUILD_DEVICES:=at91-sama5d3_xplained
+endef
+
UBOOT_TARGETS := \
at91sam9m10g45ek_nandflash \
- at91sam9x5ek_nandflash
+ at91sam9x5ek_nandflash \
+ sama5d3_xplained_nandflash \
+ sama5d3_xplained_mmc
define Build/Compile
+$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \