summaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-at91
diff options
context:
space:
mode:
authorSandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>2018-01-04 12:43:23 -0700
committerHauke Mehrtens <hauke@hauke-m.de>2018-01-09 22:58:49 +0100
commitc5292989edf9d7deb124b157600e34ffd57282cd (patch)
tree54e2e55289c2a54654c37cf71cfd5859cd951148 /package/boot/uboot-at91
parent5aabc2cd3d2255534db67ec9c5ccb62aec911deb (diff)
downloadopenwrt-c5292989edf9d7deb124b157600e34ffd57282cd.tar.gz
openwrt-c5292989edf9d7deb124b157600e34ffd57282cd.tar.bz2
openwrt-c5292989edf9d7deb124b157600e34ffd57282cd.zip
uboot-at91: fix build after fpu activation
neon and VFPv4 support is added to this target and uboot-at91 build fails due to TARGET_CFLAGS -mfloat-abi set to hard. as a fix, setting uboot-at91 CFLAGS -mfloat-abi=soft. Fixes: 01cc6bd495f ("at91: sama5: activate fpu") Signed-off-by: Sandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>
Diffstat (limited to 'package/boot/uboot-at91')
-rw-r--r--package/boot/uboot-at91/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/boot/uboot-at91/Makefile b/package/boot/uboot-at91/Makefile
index 7c420f1262..268b254206 100644
--- a/package/boot/uboot-at91/Makefile
+++ b/package/boot/uboot-at91/Makefile
@@ -88,7 +88,7 @@ UBOOT_TARGETS := \
define Build/Compile
+$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
CROSS_COMPILE=$(TARGET_CROSS) \
- KCFLAGS="$(filter-out -fstack-protector, $(TARGET_CFLAGS))"
+ KCFLAGS="$(filter-out -fstack-protector -mfloat-abi=hard, $(TARGET_CFLAGS)) -mfloat-abi=soft"
endef
$(eval $(call BuildPackage/U-Boot))