summaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-bcm4908
diff options
context:
space:
mode:
authorRafał Miłecki <rafal@milecki.pl>2022-03-15 12:40:40 +0100
committerRafał Miłecki <rafal@milecki.pl>2022-03-15 12:43:04 +0100
commit9dbca6bf6e6e088afd18fb532ed9135c21aec1cc (patch)
treec1e32bd5fd20bb5e13248035f88dd7eb019335d5 /package/boot/uboot-bcm4908
parentda2b97210cdcee893a59628455b595d6c69544f6 (diff)
downloadopenwrt-9dbca6bf6e6e088afd18fb532ed9135c21aec1cc.tar.gz
openwrt-9dbca6bf6e6e088afd18fb532ed9135c21aec1cc.tar.bz2
openwrt-9dbca6bf6e6e088afd18fb532ed9135c21aec1cc.zip
uboot-bcm4908: use "xxd" from staging_dir
This fixes: bash: xxd: command not found on hosts without xxd installed. Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
Diffstat (limited to 'package/boot/uboot-bcm4908')
-rw-r--r--package/boot/uboot-bcm4908/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/package/boot/uboot-bcm4908/Makefile b/package/boot/uboot-bcm4908/Makefile
index 489b4d69bf..dc862f4e32 100644
--- a/package/boot/uboot-bcm4908/Makefile
+++ b/package/boot/uboot-bcm4908/Makefile
@@ -32,10 +32,10 @@ define Build/Prepare
$(call Build/Prepare/Default)
mkdir -p $(PKG_BUILD_DIR)/include/generated/
( cd $(PKG_BUILD_DIR)/board/broadcom/bcmbca/httpd/html/ && \
- xxd -i index.html > ../../../../../include/generated/index.h && \
- xxd -i flashing.html > ../../../../../include/generated/flashing.h && \
- xxd -i fail.html > ../../../../../include/generated/fail.h && \
- xxd -i 404.html > ../../../../../include/generated/404.h )
+ $(STAGING_DIR_HOST)/bin/xxd -i index.html > ../../../../../include/generated/index.h && \
+ $(STAGING_DIR_HOST)/bin/xxd -i flashing.html > ../../../../../include/generated/flashing.h && \
+ $(STAGING_DIR_HOST)/bin/xxd -i fail.html > ../../../../../include/generated/fail.h && \
+ $(STAGING_DIR_HOST)/bin/xxd -i 404.html > ../../../../../include/generated/404.h )
endef
define Build/InstallDev