summaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-lantiq
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-22 15:04:04 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-22 15:14:54 +0100
commit34ec245662766354ce0d19d586bb08f220ddb3b3 (patch)
treec58b47d7d1445b05be1cb30edf84679d39a485c0 /package/boot/uboot-lantiq
parent26ae7abc156834eeeed6cdb288b93061e1bc3954 (diff)
downloadopenwrt-34ec245662766354ce0d19d586bb08f220ddb3b3.tar.gz
openwrt-34ec245662766354ce0d19d586bb08f220ddb3b3.tar.bz2
openwrt-34ec245662766354ce0d19d586bb08f220ddb3b3.zip
uboot-lantiq: fix build issue
Do not reference BIN_DIR in the package install section directly, use $(1) instead. Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/boot/uboot-lantiq')
-rw-r--r--package/boot/uboot-lantiq/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/boot/uboot-lantiq/Makefile b/package/boot/uboot-lantiq/Makefile
index cbebe91c2e..401e77ab8e 100644
--- a/package/boot/uboot-lantiq/Makefile
+++ b/package/boot/uboot-lantiq/Makefile
@@ -402,9 +402,10 @@ define Build/Compile
endef
define Package/uboot/install/default
+ $(INSTALL_DIR) $$(1)
$(CP) \
$(PKG_BUILD_DIR)/$(2) \
- $(BIN_DIR)/uboot-$(BOARD)-$(1)/openwrt-$(BOARD)-$(1)-u-boot.img
+ $$(1)/openwrt-$(BOARD)-$(1)-u-boot.img
endef
define Package/uboot/install/uart
@@ -413,7 +414,7 @@ define Package/uboot/install/uart
> $(PKG_BUILD_DIR)/ddr_settings
perl $(PKG_BUILD_DIR)/tools/gct.pl \
$(PKG_BUILD_DIR)/ddr_settings $(PKG_BUILD_DIR)/u-boot.srec \
- $(BIN_DIR)/uboot-$(BOARD)-$(1)/openwrt-$(BOARD)-$(1)-u-boot.asc
+ $$(1)/openwrt-$(BOARD)-$(1)-u-boot.asc
endef
define Package/uboot/install/template