summaryrefslogtreecommitdiffstats
path: root/package/devel
diff options
context:
space:
mode:
authorNick Hainke <vincent@systemli.org>2021-12-30 23:49:27 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2022-01-02 20:33:28 +0100
commit7df80be410ca846bbea632a9f32a189dc5afe374 (patch)
treee0a6e5d15031cab8210e9e7a699fb41cea203c61 /package/devel
parentdef9565be632b316c82ffc5a7b28c789e9df75b4 (diff)
downloadopenwrt-7df80be410ca846bbea632a9f32a189dc5afe374.tar.gz
openwrt-7df80be410ca846bbea632a9f32a189dc5afe374.tar.bz2
openwrt-7df80be410ca846bbea632a9f32a189dc5afe374.zip
binutils: fix compiling with arch-based distros
Arch Linux users have encountered problems with packages that have a dependency on binutils. This error happens when libtool is doing: libtool: relink: ... So change PKG_FIXUP to "patch-libtool". Fixes error in the form of: libtool: install: error: relink `libctf.la' with the above command before installing it Upstream Bug: https://sourceware.org/bugzilla/show_bug.cgi?id=28545 OpenWrt Bug: https://bugs.openwrt.org/index.php?do=details&task_id=4149 Acked-by: John Audia <graysky@archlinux.us> Signed-off-by: Nick Hainke <vincent@systemli.org>
Diffstat (limited to 'package/devel')
-rw-r--r--package/devel/binutils/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/devel/binutils/Makefile b/package/devel/binutils/Makefile
index 5fdb83036e..522a971051 100644
--- a/package/devel/binutils/Makefile
+++ b/package/devel/binutils/Makefile
@@ -9,14 +9,14 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=binutils
PKG_VERSION:=2.37
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_URL:=@GNU/binutils
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_VERSION:=$(PKG_VERSION)
PKG_HASH:=820d9724f020a3e69cb337893a0b63c2db161dadcb0e06fc11dc29eb1e84a32c
-PKG_FIXUP:=autoreconf
+PKG_FIXUP:=patch-libtool
PKG_LIBTOOL_PATHS:=. gas bfd opcodes gprof binutils ld libiberty gold intl
PKG_REMOVE_FILES:=libtool.m4
PKG_INSTALL:=1