summaryrefslogtreecommitdiffstats
path: root/package/firmware/linux-firmware/broadcom.mk
diff options
context:
space:
mode:
authorMarty Jones <mj8263788@gmail.com>2023-11-06 22:21:44 -0500
committerÁlvaro Fernández Rojas <noltari@gmail.com>2024-01-25 17:46:46 +0100
commitbeccf65a93a3a54d4af7cbdbff4b7d51ce52a58c (patch)
tree62566e233435ec45ca848aa39aa4a9506aa748d2 /package/firmware/linux-firmware/broadcom.mk
parent2e715fb4fc8014eefddf5d9232105740f10e06ba (diff)
downloadopenwrt-beccf65a93a3a54d4af7cbdbff4b7d51ce52a58c.tar.gz
openwrt-beccf65a93a3a54d4af7cbdbff4b7d51ce52a58c.tar.bz2
openwrt-beccf65a93a3a54d4af7cbdbff4b7d51ce52a58c.zip
linux-firmware: add Raspberry Pi 5 NVRAM
The RPi 5 expects the same NVRAM as the one from RPi 4 on a different file. Signed-off-by: Marty Jones <mj8263788@gmail.com> [Reword commit description, add missing PKG_RELEASE bump] Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Diffstat (limited to 'package/firmware/linux-firmware/broadcom.mk')
-rw-r--r--package/firmware/linux-firmware/broadcom.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/firmware/linux-firmware/broadcom.mk b/package/firmware/linux-firmware/broadcom.mk
index 4f64b423eb..088a2665cc 100644
--- a/package/firmware/linux-firmware/broadcom.mk
+++ b/package/firmware/linux-firmware/broadcom.mk
@@ -127,7 +127,13 @@ define Package/brcmfmac-nvram-43455-sdio/install
$(1)/lib/firmware/brcm/brcmfmac43455-sdio.Raspberry\ Pi\ Foundation-Raspberry\ Pi\ 4\ Model\ B.txt
$(LN) \
brcmfmac43455-sdio.raspberrypi,4-model-b.txt \
+ $(1)/lib/firmware/brcm/brcmfmac43455-sdio.raspberrypi,5-model-b.txt
+ $(LN) \
+ brcmfmac43455-sdio.raspberrypi,4-model-b.txt \
$(1)/lib/firmware/brcm/brcmfmac43455-sdio.Raspberry\ Pi\ Foundation-Raspberry\ Pi\ Compute\ Module\ 4.txt
+ $(LN) \
+ brcmfmac43455-sdio.raspberrypi,4-model-b.txt \
+ $(1)/lib/firmware/brcm/brcmfmac43455-sdio.Raspberry\ Pi\ Foundation-Raspberry\ Pi\ 5\ Model\ B.txt
$(INSTALL_DATA) \
$(PKG_BUILD_DIR)/brcm/brcmfmac43455-sdio.MINIX-NEO\ Z83-4.txt \
$(1)/lib/firmware/brcm/