summaryrefslogtreecommitdiffstats
path: root/package/hostapd
diff options
context:
space:
mode:
authorTravis Kemen <thepeople@openwrt.org>2010-03-24 00:22:19 +0000
committerTravis Kemen <thepeople@openwrt.org>2010-03-24 00:22:19 +0000
commit22b92b3e13853dd592c9c9677477c6caf0d1a6bf (patch)
tree357d21587435b11ec44f60d0a3f98ed74d9bfe83 /package/hostapd
parent21f006f1568670abb82a7ae6cd2fb1c379c8df3b (diff)
downloadopenwrt-22b92b3e13853dd592c9c9677477c6caf0d1a6bf.tar.gz
openwrt-22b92b3e13853dd592c9c9677477c6caf0d1a6bf.tar.bz2
openwrt-22b92b3e13853dd592c9c9677477c6caf0d1a6bf.zip
Enable management frame protection in hostapd, and make it configurable in /etc/config/wireless. Since ath9k is currently the only driver that supports MFP, it will only be enabled when ath9k is enabled.
Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be> SVN-Revision: 20396
Diffstat (limited to 'package/hostapd')
-rw-r--r--package/hostapd/Makefile3
-rw-r--r--package/hostapd/files/hostapd.sh7
2 files changed, 9 insertions, 1 deletions
diff --git a/package/hostapd/Makefile b/package/hostapd/Makefile
index 002cd5328b..4c261f3cae 100644
--- a/package/hostapd/Makefile
+++ b/package/hostapd/Makefile
@@ -54,7 +54,8 @@ DRIVER_MAKEOPTS= \
CONFIG_DRIVER_NL80211=$(CONFIG_PACKAGE_kmod-mac80211) \
CONFIG_DRIVER_MADWIFI=$(CONFIG_PACKAGE_kmod-madwifi) \
CONFIG_DRIVER_HOSTAP=$(CONFIG_PACKAGE_kmod-hostap) \
- CONFIG_IEEE80211N=$(CONFIG_PACKAGE_kmod-ath9k)
+ CONFIG_IEEE80211N=$(CONFIG_PACKAGE_kmod-ath9k) \
+ CONFIG_IEEE80211W=$(CONFIG_PACKAGE_kmod-ath9k)
ifeq ($(LOCAL_TYPE),supplicant)
ifeq ($(LOCAL_VARIANT),full)
diff --git a/package/hostapd/files/hostapd.sh b/package/hostapd/files/hostapd.sh
index c83c06df86..78dcf82f0b 100644
--- a/package/hostapd/files/hostapd.sh
+++ b/package/hostapd/files/hostapd.sh
@@ -106,6 +106,13 @@ hostapd_set_bss_options() {
append "$var" "ssid=$ssid" "$N"
[ -n "$bridge" ] && append "$var" "bridge=$bridge" "$N"
[ -n "$ieee80211d" ] && append "$var" "ieee80211d=$ieee80211d" "$N"
+
+ [ "$wpa" -ge "2" ] && config_get ieee80211w "$vif" ieee80211w
+ case "$ieee80211w" in
+ [012])
+ append "$var" "ieee80211w=$ieee80211w" "$N"
+ ;;
+ esac
}
hostapd_setup_vif() {