summaryrefslogtreecommitdiffstats
path: root/package/kernel/ath10k-ct/Makefile
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2018-04-15 12:47:43 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2018-04-18 23:57:12 +0200
commit97a3e69f61cad8f9a639dc65a3dcda37dfdd1a9f (patch)
treec22ed2dd14a82e79f57a6fb722774ead969c1821 /package/kernel/ath10k-ct/Makefile
parenta330ecebf57e71bb489ccf8e5f049ccf982e1bfc (diff)
downloadopenwrt-97a3e69f61cad8f9a639dc65a3dcda37dfdd1a9f.tar.gz
openwrt-97a3e69f61cad8f9a639dc65a3dcda37dfdd1a9f.tar.bz2
openwrt-97a3e69f61cad8f9a639dc65a3dcda37dfdd1a9f.zip
ath10k-ct: make it depend on PCI support again
The missing dependency causes build problems on systems without PCI support. The ath10k_pci kernel module depends on PCI support so this dependency should be added. ath10k now also supported the ahb interface on the IPQ4019 SoC, but this SoC also has PCI support so this extra dependency is not as problem. Fixes: d0f3dd5b9f34176 ("ath10k-ct: update to latest version, enable AHB.") Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'package/kernel/ath10k-ct/Makefile')
-rw-r--r--package/kernel/ath10k-ct/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/ath10k-ct/Makefile b/package/kernel/ath10k-ct/Makefile
index 1725bb7d17..9c69dee72f 100644
--- a/package/kernel/ath10k-ct/Makefile
+++ b/package/kernel/ath10k-ct/Makefile
@@ -29,7 +29,7 @@ include $(INCLUDE_DIR)/package.mk
define KernelPackage/ath10k-ct
SUBMENU:=Wireless Drivers
TITLE:=ath10k-ct driver optimized for CT ath10k firmware
- DEPENDS:=+kmod-mac80211 +kmod-ath +@DRIVER_11N_SUPPORT +@DRIVER_11AC_SUPPORT +@DRIVER_11W_SUPPORT +kmod-hwmon-core
+ DEPENDS:=+kmod-mac80211 +kmod-ath +@DRIVER_11N_SUPPORT +@DRIVER_11AC_SUPPORT +@DRIVER_11W_SUPPORT @PCI_SUPPORT +kmod-hwmon-core
FILES:=\
$(PKG_BUILD_DIR)/ath10k$(CT_KVER)/ath10k_pci.ko \
$(PKG_BUILD_DIR)/ath10k$(CT_KVER)/ath10k_core.ko