summaryrefslogtreecommitdiffstats
path: root/package/kernel/lantiq/ltq-vmmc/Makefile
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2024-04-03 22:54:51 +0100
committerDaniel Golle <daniel@makrotopia.org>2024-04-04 15:12:45 +0100
commit000d25c31257e981309ea5d57c6c90337736f0bf (patch)
tree005e16d1127a58d29ebbe51d7a394015bb0e1845 /package/kernel/lantiq/ltq-vmmc/Makefile
parent4ef13c4a49708d361df663a6e42e6e114a71c020 (diff)
downloadopenwrt-000d25c31257e981309ea5d57c6c90337736f0bf.tar.gz
openwrt-000d25c31257e981309ea5d57c6c90337736f0bf.tar.bz2
openwrt-000d25c31257e981309ea5d57c6c90337736f0bf.zip
kernel: ltq-vmmc: fix compilation warning/error
Fix compilation warning enum-int-mismatch which results in failure to build kmod-ltq-vmmc in case CONFIG_KERNEL_WERROR is set. .../build_dir/target-mips_24kc_musl/linux-lantiq_xrx200/drv_vmmc-1.9.0/src/mps/drv_mps_vmmc_common.c:392:14: error: conflicting types for 'ifx_mps_fastbuf_init' due to enum/integer mismatch; have 'IFX_return_t(void)' [-Werror=enum-int-mismatch] 392 | IFX_return_t ifx_mps_fastbuf_init (IFX_void_t) | ^~~~~~~~~~~~~~~~~~~~ .../build_dir/target-mips_24kc_musl/linux-lantiq_xrx200/drv_vmmc-1.9.0/src/mps/drv_mps_vmmc_common.c:120:13: note: previous declaration of 'ifx_mps_fastbuf_init' with type 'IFX_int32_t(void)' {aka 'int(void)'} 120 | IFX_int32_t ifx_mps_fastbuf_init (IFX_void_t); | ^~~~~~~~~~~~~~~~~~~~ .../build_dir/target-mips_24kc_musl/linux-lantiq_xrx200/drv_vmmc-1.9.0/src/mps/drv_mps_vmmc_common.c:420:14: error: conflicting types for 'ifx_mps_fastbuf_close' due to enum/integer mismatch; have 'IFX_return_t(void)' [-Werror=enum-int-mismatch] 420 | IFX_return_t ifx_mps_fastbuf_close (IFX_void_t) | ^~~~~~~~~~~~~~~~~~~~~ .../build_dir/target-mips_24kc_musl/linux-lantiq_xrx200/drv_vmmc-1.9.0/src/mps/drv_mps_vmmc_common.c:121:13: note: previous declaration of 'ifx_mps_fastbuf_close' with type 'IFX_int32_t(void)' {aka 'int(void)'} 121 | IFX_int32_t ifx_mps_fastbuf_close (IFX_void_t); | ^~~~~~~~~~~~~~~~~~~~~ cc1: all warnings being treated as errors Refresh patches and bump PKG_RELEASE while at it. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'package/kernel/lantiq/ltq-vmmc/Makefile')
-rw-r--r--package/kernel/lantiq/ltq-vmmc/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/lantiq/ltq-vmmc/Makefile b/package/kernel/lantiq/ltq-vmmc/Makefile
index 4972f1c374..8cd6b3de45 100644
--- a/package/kernel/lantiq/ltq-vmmc/Makefile
+++ b/package/kernel/lantiq/ltq-vmmc/Makefile
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=drv_vmmc
PKG_VERSION:=1.9.0
-PKG_RELEASE:=4
+PKG_RELEASE:=5
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_HASH:=707f515eb727c032418c4da67d7e86884bb56cdc2a606e8f6ded6057d8767e57