summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/iio.mk
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2017-10-18 20:17:56 +0300
committerStijn Tintel <stijn@linux-ipv6.be>2017-10-23 12:50:30 +0300
commit683350873e18f592124cb2cce771d5459d27b2bd (patch)
tree13c10b13ea5163eb8ff4558a96a177b6e7c6c00f /package/kernel/linux/modules/iio.mk
parent19a7f44a5a340cb74f03c6dcc11d9541806d5495 (diff)
downloadopenwrt-683350873e18f592124cb2cce771d5459d27b2bd.tar.gz
openwrt-683350873e18f592124cb2cce771d5459d27b2bd.tar.bz2
openwrt-683350873e18f592124cb2cce771d5459d27b2bd.zip
kernel: add kmod-iio-bmp280
This driver supports the Bosch Sensortec BMP180/BMP280 pressure and temperature sensors. It also supports the BME280 sensors with an additional humidity channel. Tested I2C and SPI modes with a BME280 sensor on a Raspberry Pi Zero W. Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Diffstat (limited to 'package/kernel/linux/modules/iio.mk')
-rw-r--r--package/kernel/linux/modules/iio.mk48
1 files changed, 48 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/iio.mk b/package/kernel/linux/modules/iio.mk
index 29ccd6a07c..396ee7fbe4 100644
--- a/package/kernel/linux/modules/iio.mk
+++ b/package/kernel/linux/modules/iio.mk
@@ -70,3 +70,51 @@ define KernelPackage/iio-dht11/description
endef
$(eval $(call KernelPackage,iio-dht11))
+
+define KernelPackage/iio-bmp280
+ SUBMENU:=$(IIO_MENU)
+ TITLE:=BMP180/BMP280/BME280 pressure/temperatur sensor
+ DEPENDS:=@LINUX_4_9 +kmod-iio-core +kmod-regmap
+ KCONFIG:=CONFIG_BMP280
+ FILES:=$(LINUX_DIR)/drivers/iio/pressure/bmp280.ko
+endef
+
+define KernelPackage/iio-bmp280/description
+ This driver adds support for Bosch Sensortec BMP180 and BMP280 pressure and
+ temperature sensors. Also supports the BME280 with an additional humidity
+ sensor channel.
+endef
+
+$(eval $(call KernelPackage,iio-bmp280))
+
+
+define KernelPackage/iio-bmp280-i2c
+ SUBMENU:=$(IIO_MENU)
+ TITLE:=BMP180/BMP280/BME280 pressure/temperatur sensor (I2C)
+ DEPENDS:=+kmod-iio-bmp280 +kmod-i2c-core
+ KCONFIG:=CONFIG_BMP280_I2C
+ FILES:=$(LINUX_DIR)/drivers/iio/pressure/bmp280-i2c.ko
+ AUTOLOAD:=$(call AutoProbe,iio-bmp280-i2c)
+endef
+define KernelPackage/iio-bmp280-i2c/description
+ This driver adds support for Bosch Sensortec's digital pressure and
+ temperature sensor connected via I2C.
+endef
+
+$(eval $(call KernelPackage,iio-bmp280-i2c))
+
+
+define KernelPackage/iio-bmp280-spi
+ SUBMENU:=$(IIO_MENU)
+ TITLE:=BMP180/BMP280/BME280 pressure/temperatur sensor (SPI)
+ DEPENDS:=+kmod-iio-bmp280 +kmod-spi-bitbang
+ KCONFIG:=CONFIG_BMP280_SPI
+ FILES:=$(LINUX_DIR)/drivers/iio/pressure/bmp280-spi.ko
+ AUTOLOAD:=$(call AutoProbe,iio-bmp280-spi)
+endef
+define KernelPackage/iio-bmp280-spi/description
+ This driver adds support for Bosch Sensortec's digital pressure and
+ temperature sensor connected via SPI.
+endef
+
+$(eval $(call KernelPackage,iio-bmp280-spi))