summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/iio.mk
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2019-02-05 02:25:22 +0200
committerStijn Tintel <stijn@linux-ipv6.be>2019-02-23 17:22:53 +0200
commite03deb8cae83a1cd465b4efc5b572525b0ac74c7 (patch)
tree72800eb3e5d059e3e65394bc52eb04a016cfa579 /package/kernel/linux/modules/iio.mk
parentc17a68cc61a0f8a28e19c7f60b24beaf1a1a402d (diff)
downloadopenwrt-e03deb8cae83a1cd465b4efc5b572525b0ac74c7.tar.gz
openwrt-e03deb8cae83a1cd465b4efc5b572525b0ac74c7.tar.bz2
openwrt-e03deb8cae83a1cd465b4efc5b572525b0ac74c7.zip
kernel: add kmod-iio-ccs811
This module supports the AMS CCS811 VOC sensor. Tested on Raspberry Pi Zero W and ODROID C2. Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Diffstat (limited to 'package/kernel/linux/modules/iio.mk')
-rw-r--r--package/kernel/linux/modules/iio.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/iio.mk b/package/kernel/linux/modules/iio.mk
index fe682b3100..44a4806b34 100644
--- a/package/kernel/linux/modules/iio.mk
+++ b/package/kernel/linux/modules/iio.mk
@@ -200,6 +200,23 @@ endef
$(eval $(call KernelPackage,iio-htu21))
+define KernelPackage/iio-ccs811
+ SUBMENU:=$(IIO_MENU)
+ DEPENDS:=+kmod-i2c-core +kmod-iio-core
+ TITLE:=AMS CCS811 VOC sensor
+ KCONFIG:= \
+ CONFIG_CCS811
+ FILES:= $(LINUX_DIR)/drivers/iio/chemical/ccs811.ko
+ AUTOLOAD:=$(call AutoLoad,56,ccs811)
+endef
+
+define KernelPackage/iio-ccs811/description
+ Support for the AMS CCS811 VOC (Volatile Organic Compounds) sensor
+endef
+
+$(eval $(call KernelPackage,iio-ccs811))
+
+
define KernelPackage/iio-si7020
SUBMENU:=$(IIO_MENU)
DEPENDS:=+kmod-i2c-core +kmod-iio-core