summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/iio.mk
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke.mehrtens@intel.com>2019-01-11 18:05:11 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2019-01-27 00:16:13 +0100
commitfd5c16870169bb76dd3d3bcfbcc6a112f74aeefe (patch)
tree43db8ee2a39320df1ebc4a3e03bf22719ec45e6d /package/kernel/linux/modules/iio.mk
parent538127cf981e0f7f71a75b365d95575b0f7263e1 (diff)
downloadopenwrt-fd5c16870169bb76dd3d3bcfbcc6a112f74aeefe.tar.gz
openwrt-fd5c16870169bb76dd3d3bcfbcc6a112f74aeefe.tar.bz2
openwrt-fd5c16870169bb76dd3d3bcfbcc6a112f74aeefe.zip
kernel: Build: Split kmod-regmap
This reduces the needed modifications to the mainline Linux kernel and also makes the regmap package work with an out of tree kernel which does not have these modifications. The regmap-core is only added when it is really build as a module. The regmap-core is normally bool so it cannot be built as a module in an unmodified kernel. When it is selected by on other kernel module it will always be selected as build in and it also does not show up in $(LINUX_DIR)/modules.builtin as it is not supposed to be a kernel module. When it is not in $(LINUX_DIR)/modules.builtin the build system expects it to be built as a .ko file. Just check if the module is really there and only add it in that case. This splits the regmap package into multiple packages, one for each bus type. This way only the bus maps which are really needed have to be added. This also splits the I2C, SPI and MMIO regmap into separate packages to not require all these subsystems to build them, on an unmodified upstream kernel this also causes problems in some situations. Signed-off-by: Hauke Mehrtens <hauke.mehrtens@intel.com>
Diffstat (limited to 'package/kernel/linux/modules/iio.mk')
-rw-r--r--package/kernel/linux/modules/iio.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/kernel/linux/modules/iio.mk b/package/kernel/linux/modules/iio.mk
index ee82eee71e..fe682b3100 100644
--- a/package/kernel/linux/modules/iio.mk
+++ b/package/kernel/linux/modules/iio.mk
@@ -54,7 +54,7 @@ $(eval $(call KernelPackage,iio-ad799x))
define KernelPackage/iio-hmc5843
SUBMENU:=$(IIO_MENU)
- DEPENDS:=+kmod-i2c-core +kmod-iio-core +kmod-regmap
+ DEPENDS:=+kmod-i2c-core +kmod-iio-core +kmod-regmap-i2c
TITLE:=Honeywell HMC58x3 Magnetometer
KCONFIG:= CONFIG_SENSORS_HMC5843_I2C
FILES:= \
@@ -132,7 +132,7 @@ $(eval $(call KernelPackage,iio-dht11))
define KernelPackage/iio-bmp280
SUBMENU:=$(IIO_MENU)
TITLE:=BMP180/BMP280/BME280 pressure/temperatur sensor
- DEPENDS:=@!LINUX_3_18 +kmod-iio-core +kmod-regmap
+ DEPENDS:=@!LINUX_3_18 +kmod-iio-core +kmod-regmap-core
KCONFIG:=CONFIG_BMP280
FILES:=$(LINUX_DIR)/drivers/iio/pressure/bmp280.ko
endef
@@ -149,7 +149,7 @@ $(eval $(call KernelPackage,iio-bmp280))
define KernelPackage/iio-bmp280-i2c
SUBMENU:=$(IIO_MENU)
TITLE:=BMP180/BMP280/BME280 pressure/temperatur sensor (I2C)
- DEPENDS:=+kmod-iio-bmp280 +kmod-i2c-core
+ DEPENDS:=+kmod-iio-bmp280 +kmod-i2c-core +kmod-regmap-i2c
KCONFIG:=CONFIG_BMP280_I2C
FILES:=$(LINUX_DIR)/drivers/iio/pressure/bmp280-i2c.ko
AUTOLOAD:=$(call AutoProbe,iio-bmp280-i2c)