summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
authorFlorian Eckert <fe@dev.tdt.de>2020-04-29 15:54:06 +0200
committerPetr Štetiar <ynezz@true.cz>2020-06-03 16:49:28 +0200
commit0b3e1205df64f14a7a06d354abc574cb59cad0c3 (patch)
tree72ff8342e9e190d59cb142fe17957a5b48aa2a40 /package/kernel/linux/modules/other.mk
parent1d9812f48aa1f57a8917d3351f0a4f7c8d559755 (diff)
downloadopenwrt-0b3e1205df64f14a7a06d354abc574cb59cad0c3.tar.gz
openwrt-0b3e1205df64f14a7a06d354abc574cb59cad0c3.tar.bz2
openwrt-0b3e1205df64f14a7a06d354abc574cb59cad0c3.zip
kernel: add gpio-it87
Since commit 910df3f06cc902ca2cb0ca8e963e9354c930df1a we have build in on all X86/64 platforms the gpio-it87 driver. Since this change I am getting the following error message on boot. > kern.err kernel: [ 1.009416] gpio_it87: no device I do not have this device on my system. To prevent the nonsensical message and the loading of the module I have added this as a package, so that it can be installed later or during image building. Signed-off-by: Florian Eckert <fe@dev.tdt.de> Reviewed-by: Philip Prindeville <philipp@redfish-solutions.com>
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index f05c758340..2cd4765196 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -295,6 +295,24 @@ endef
$(eval $(call KernelPackage,gpio-pcf857x))
+define KernelPackage/gpio-it87
+ SUBMENU:=$(OTHER_MENU)
+ DEPENDS:=@GPIO_SUPPORT @TARGET_x86
+ TITLE:=GPIO support for IT87xx Super I/O chips
+ KCONFIG:=CONFIG_GPIO_IT87
+ FILES:=$(LINUX_DIR)/drivers/gpio/gpio-it87.ko
+ AUTOLOAD:=$(call AutoLoad,25,gpio-it87,1)
+endef
+
+define KernelPackage/gpio-it87/description
+ This driver is tested with ITE IT8728 and IT8732 Super I/O chips, and
+ supports the IT8761E, IT8613, IT8620E, and IT8628E Super I/O chips as
+ well.
+endef
+
+$(eval $(call KernelPackage,gpio-it87))
+
+
define KernelPackage/ppdev
SUBMENU:=$(OTHER_MENU)
TITLE:=Parallel port support