summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
authorFlorian Eckert <fe@dev.tdt.de>2022-01-26 15:29:18 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2022-10-30 23:14:45 +0100
commit1dccc6e74984e62f1e4cde70028bd422dbc37979 (patch)
tree71e44a7fb9831b8f4872a1494bdb3287a0081908 /package/kernel/linux/modules/other.mk
parentcc5d8ae42731b50469ab92ed00be3cfc83d4ce11 (diff)
downloadopenwrt-1dccc6e74984e62f1e4cde70028bd422dbc37979.tar.gz
openwrt-1dccc6e74984e62f1e4cde70028bd422dbc37979.tar.bz2
openwrt-1dccc6e74984e62f1e4cde70028bd422dbc37979.zip
kernel: replace gpio-mcp23s08 with pinctrl-mcp23s08*
The kernel module gpio-mcp23s08 has been replaced by the new pinctrl-mcp23s08* kernel modules. There are now 3 kernel modules for this device - Common module for both I2C and SPI kmod-pinctrl-mcp23s08 - Module for I2C kmod-pinctrl-mcp23s08-i2c - Module for SPI kmod-pinctrl-mcp23s08-spi Signed-off-by: Florian Eckert <fe@dev.tdt.de>
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk53
1 files changed, 43 insertions, 10 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index f15a08d62e..46f5dea7ae 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -242,23 +242,56 @@ endef
$(eval $(call KernelPackage,gpio-f7188x))
-define KernelPackage/gpio-mcp23s08
+define KernelPackage/pinctrl-mcp23s08
SUBMENU:=$(OTHER_MENU)
TITLE:=Microchip MCP23xxx I/O expander
- DEPENDS:=@GPIO_SUPPORT +kmod-i2c-core +kmod-regmap-i2c
- KCONFIG:= \
- CONFIG_GPIO_MCP23S08 \
- CONFIG_PINCTRL_MCP23S08
- FILES:= \
- $(LINUX_DIR)/drivers/pinctrl/pinctrl-mcp23s08.ko
+ HIDDEN:=1
+ DEPENDS:=@GPIO_SUPPORT +kmod-regmap-core
+ KCONFIG:=CONFIG_PINCTRL_MCP23S08
+ FILES:=$(LINUX_DIR)/drivers/pinctrl/pinctrl-mcp23s08.ko
AUTOLOAD:=$(call AutoLoad,40,pinctrl-mcp23s08)
endef
-define KernelPackage/gpio-mcp23s08/description
- Kernel module for Microchip MCP23xxx SPI/I2C I/O expander
+define KernelPackage/pinctrl-mcp23s08/description
+ Kernel module for Microchip MCP23xxx I/O expander
+endef
+
+$(eval $(call KernelPackage,pinctrl-mcp23s08))
+
+
+define KernelPackage/pinctrl-mcp23s08-i2c
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Microchip MCP23xxx I/O expander (I2C)
+ DEPENDS:=@GPIO_SUPPORT \
+ +kmod-pinctrl-mcp23s08 \
+ +kmod-i2c-core \
+ +kmod-regmap-i2c
+ KCONFIG:=CONFIG_PINCTRL_MCP23S08_I2C
+ FILES:=$(LINUX_DIR)/drivers/pinctrl/pinctrl-mcp23s08_i2c.ko
+ AUTOLOAD:=$(call AutoLoad,40,pinctrl-mcp23s08-i2c)
+endef
+
+define KernelPackage/pinctrl-mcp23s08-i2c/description
+ Kernel module for Microchip MCP23xxx I/O expander via I2C
+endef
+
+$(eval $(call KernelPackage,pinctrl-mcp23s08-i2c))
+
+
+define KernelPackage/pinctrl-mcp23s08-spi
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Microchip MCP23xxx I/O expander (SPI)
+ DEPENDS:=@GPIO_SUPPORT +kmod-pinctrl-mcp23s08
+ KCONFIG:=CONFIG_PINCTRL_MCP23S08_SPI
+ FILES:=$(LINUX_DIR)/drivers/pinctrl/pinctrl-mcp23s08_spi.ko
+ AUTOLOAD:=$(call AutoLoad,40,pinctrl-mcp23s08-spi)
+endef
+
+define KernelPackage/pinctrl-mcp23s08-spi/description
+ Kernel module for Microchip MCP23xxx I/O expander via SPI
endef
-$(eval $(call KernelPackage,gpio-mcp23s08))
+$(eval $(call KernelPackage,pinctrl-mcp23s08-spi))
define KernelPackage/gpio-nxp-74hc164