summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
authorSungbo Eo <mans0n@gorani.run>2021-01-03 22:40:01 +0900
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-01-15 17:47:33 +0100
commit218eff5bdbffbb92e222ba0183ae25220d2defe3 (patch)
tree3bc0134ee5679b5c5d79a12c2f65a230c0786732 /package/kernel/linux/modules/other.mk
parent5beea4c3fd6b671e102430ba934442f69b1332b0 (diff)
downloadopenwrt-218eff5bdbffbb92e222ba0183ae25220d2defe3.tar.gz
openwrt-218eff5bdbffbb92e222ba0183ae25220d2defe3.tar.bz2
openwrt-218eff5bdbffbb92e222ba0183ae25220d2defe3.zip
kernel: update kmod-thermal package
CONFIG_THERMAL option was changed to boolean in upstream linux commit 554b3529fe01 ("thermal/drivers/core: Remove the module Kconfig's option"). Switch it to 'y' and remove FILES and AUTOLOAD for non-existant module file. And update the descripton text for the package as in upstream linux commit eb8504620381 ("thermal: Rephrase the Kconfig text for thermal"). Signed-off-by: Sungbo Eo <mans0n@gorani.run>
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk11
1 files changed, 4 insertions, 7 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 421b1b536c..83d998c83a 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -1039,11 +1039,11 @@ $(eval $(call KernelPackage,random-core))
define KernelPackage/thermal
SUBMENU:=$(OTHER_MENU)
- TITLE:=Generic Thermal sysfs driver
+ TITLE:=Thermal driver
DEPENDS:=+kmod-hwmon-core
HIDDEN:=1
KCONFIG:= \
- CONFIG_THERMAL \
+ CONFIG_THERMAL=y \
CONFIG_THERMAL_OF=y \
CONFIG_CPU_THERMAL=y \
CONFIG_THERMAL_DEFAULT_GOV_STEP_WISE=y \
@@ -1055,14 +1055,11 @@ define KernelPackage/thermal
CONFIG_THERMAL_GOV_USER_SPACE=n \
CONFIG_THERMAL_HWMON=y \
CONFIG_THERMAL_EMULATION=n
- FILES:=$(LINUX_DIR)/drivers/thermal/thermal_sys.ko
- AUTOLOAD:=$(call AutoProbe,thermal_sys)
endef
define KernelPackage/thermal/description
- Generic Thermal Sysfs driver offers a generic mechanism for thermal
- management. Usually it's made up of one or more thermal zone and cooling
- device.
+ Thermal driver offers a generic mechanism for thermal management.
+ Usually it's made up of one or more thermal zone and cooling device.
endef
$(eval $(call KernelPackage,thermal))