summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
authorIlya Lipnitskiy <ilya.lipnitskiy@gmail.com>2021-02-19 08:21:24 -0800
committerDavid Bauer <mail@david-bauer.net>2021-02-23 20:13:22 +0100
commit30b482551d838f0a4a2d0d024a28ac6393f6ab9c (patch)
treeab7934a8247e00324214d06da71d63070072aba9 /package/kernel/linux/modules/other.mk
parent57fdcf66f0c2ae4410a169dfbc1bd5a2c66771b0 (diff)
downloadopenwrt-30b482551d838f0a4a2d0d024a28ac6393f6ab9c.tar.gz
openwrt-30b482551d838f0a4a2d0d024a28ac6393f6ab9c.tar.bz2
openwrt-30b482551d838f0a4a2d0d024a28ac6393f6ab9c.zip
kernel: 5.10: fix kmod build failures
Modify existing modules to reflect their new location in Linux 5.10. Add missing dependenices. Signed-off-by: Ilya Lipnitskiy <ilya.lipnitskiy@gmail.com> [enable CRYPTO_USER_API_ENABLE_OBSOLETE; add kmod-crypto-hash dependency to usb-net-rtl8152] Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 83d998c83a..cfd133f19f 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -1126,7 +1126,9 @@ define KernelPackage/keys-trusted
TITLE:=TPM trusted keys on kernel keyring
DEPENDS:=@KERNEL_KEYS +kmod-crypto-hash +kmod-crypto-hmac +kmod-crypto-sha1 +kmod-tpm
KCONFIG:=CONFIG_TRUSTED_KEYS
- FILES:=$(LINUX_DIR)/security/keys/trusted.ko
+ FILES:= \
+ $(LINUX_DIR)/security/keys/trusted.ko@lt5.10 \
+ $(LINUX_DIR)/security/keys/trusted-keys/trusted.ko@ge5.10
AUTOLOAD:=$(call AutoLoad,01,trusted-keys,1)
endef