summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
authorNick Bowler <nbowler@draconx.ca>2020-03-24 22:00:29 -0400
committerPetr Štetiar <ynezz@true.cz>2020-03-28 13:03:02 +0100
commit3ad0cf7d9303bd941b04ec9329604a1408767816 (patch)
treead929501b555f562c32c1db8ab1fd2b242287500 /package/kernel/linux/modules/other.mk
parent922dfe0fa0d999f2861f7b5fd1cf34d4a3f59454 (diff)
downloadopenwrt-3ad0cf7d9303bd941b04ec9329604a1408767816.tar.gz
openwrt-3ad0cf7d9303bd941b04ec9329604a1408767816.tar.bz2
openwrt-3ad0cf7d9303bd941b04ec9329604a1408767816.zip
kernel: package f71808e-wdt driver
This driver enables support for the watchdog timers found in many Fintek Super-IO chips. Signed-off-by: Nick Bowler <nbowler@draconx.ca>
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index f1a70bf069..1f13cb7aa7 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -1228,3 +1228,19 @@ define KernelPackage/it87-wdt/description
endef
$(eval $(call KernelPackage,it87-wdt))
+
+
+define KernelPackage/f71808e-wdt
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Fintek F718xx/F818xx Watchdog Timer
+ DEPENDS:=@TARGET_x86
+ KCONFIG:=CONFIG_F71808E_WDT
+ FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/f71808e_wdt.ko
+ AUTOLOAD:=$(call AutoProbe,f71808e-wdt,1)
+endef
+
+define KernelPackage/f71808e-wdt/description
+ Kernel module for the watchdog timer found on many Fintek Super-IO chips.
+endef
+
+$(eval $(call KernelPackage,f71808e-wdt))