summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
authorLinus Walleij <linus.walleij@linaro.org>2023-10-12 10:42:18 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2023-10-20 13:27:28 +0200
commit806b359bbc07cb21a41091f2c76ed682a02b55aa (patch)
tree6860acb58a2f65fb73bf9ace7fb5aaf8bf6d76fc /package/kernel/linux/modules/other.mk
parent743dc8dd1592989157cfb34d9b8b1d61466b247c (diff)
downloadopenwrt-806b359bbc07cb21a41091f2c76ed682a02b55aa.tar.gz
openwrt-806b359bbc07cb21a41091f2c76ed682a02b55aa.tar.bz2
openwrt-806b359bbc07cb21a41091f2c76ed682a02b55aa.zip
kernel: Add kmod-rtc-x1205
To support the IXP42x platforms we need a kernel module for the X1205 RTC so we can load it as an optional module. Signed-off-by: Linus Walleij <linus.walleij@linaro.org> Reviewed-by: Robert Marko <robimarko@gmail.com>
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index ac26c2a150..2cd01d84d5 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -780,6 +780,22 @@ endef
$(eval $(call KernelPackage,rtc-s35390a))
+define KernelPackage/rtc-x1205
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Xicor Intersil X1205
+ DEFAULT:=m if ALL_KMODS && RTC_SUPPORT
+ DEPENDS:=+kmod-i2c-core
+ KCONFIG:=CONFIG_RTC_DRV_X1205 \
+ CONFIG_RTC_CLASS=y
+ FILES:=$(LINUX_DIR)/drivers/rtc/rtc-x1205.ko
+ AUTOLOAD:=$(call AutoProbe,rtc-x1205)
+endef
+
+define KernelPackage/rtc-x1205/description
+ Kernel module for Xicor Intersil X1205 I2C RTC chip
+endef
+
+$(eval $(call KernelPackage,rtc-x1205))
define KernelPackage/mtdtests
SUBMENU:=$(OTHER_MENU)