summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
authorPawel Dembicki <paweldembicki@gmail.com>2020-01-24 07:25:54 +0100
committerPetr Štetiar <ynezz@true.cz>2020-07-11 13:33:28 +0200
commit9c99187e616ac54aed572a0eb310aadd06ac8e4b (patch)
treeeafbf42d6aa17a28132435b7806e74e2aec3587a /package/kernel/linux/modules/other.mk
parent7d97fe55f422d37ec6907b9c1609b42688315dd7 (diff)
downloadopenwrt-9c99187e616ac54aed572a0eb310aadd06ac8e4b.tar.gz
openwrt-9c99187e616ac54aed572a0eb310aadd06ac8e4b.tar.bz2
openwrt-9c99187e616ac54aed572a0eb310aadd06ac8e4b.zip
kernel: add package for Seiko S-35390A I2C RTC
This patch adds kernel package for Seiko Instruments S-35390A. Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 15d67b4679..f74c622ed7 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -732,6 +732,23 @@ endef
$(eval $(call KernelPackage,rtc-rx8025))
+define KernelPackage/rtc-s35390a
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Seico S-35390A
+ DEFAULT:=m if ALL_KMODS && RTC_SUPPORT
+ DEPENDS:=+kmod-i2c-core
+ KCONFIG:=CONFIG_RTC_DRV_S35390A \
+ CONFIG_RTC_CLASS=y
+ FILES:=$(LINUX_DIR)/drivers/rtc/rtc-s35390a.ko
+ AUTOLOAD:=$(call AutoLoad,50,rtc-s35390a,1)
+endef
+
+define KernelPackage/rtc-s35390a/description
+ Kernel module for Seiko Instruments S-35390A I2C RTC chip
+endef
+
+$(eval $(call KernelPackage,rtc-s35390a))
+
define KernelPackage/mtdtests
SUBMENU:=$(OTHER_MENU)