summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
authorBrian Norris <computersforpeace@gmail.com>2023-02-04 16:35:33 -0800
committerHauke Mehrtens <hauke@hauke-m.de>2023-02-18 19:58:22 +0100
commita3adbec37061e56e7161f28140272cdd86b1dc38 (patch)
treeb26ea0059573530096dd9be5161215cc6b486caa /package/kernel/linux/modules/other.mk
parentefbb623debef3c63eebc9b849f6ca57130efa5f4 (diff)
downloadopenwrt-a3adbec37061e56e7161f28140272cdd86b1dc38.tar.gz
openwrt-a3adbec37061e56e7161f28140272cdd86b1dc38.tar.bz2
openwrt-a3adbec37061e56e7161f28140272cdd86b1dc38.zip
kernel: kmod-ramoops: Include pstore console support
Pstore ramoops support is useful even when there isn't an explicit panic/crash. We can log all kernel messages via a "console", and then retrieve them in the event of some non-kernel-panic reset (e.g., watchdog). Since the buffer memory is already reserved, there isn't much overhead to doing this. The new console files will show up as: /sys/fs/pstore/console-ramoops-N Cc: Hannu Nyman <hannu.nyman@iki.fi> Signed-off-by: Brian Norris <computersforpeace@gmail.com>
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 2bd15dfe67..1369a4ad54 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -834,7 +834,8 @@ define KernelPackage/ramoops
SUBMENU:=$(OTHER_MENU)
TITLE:=Ramoops (pstore-ram)
DEFAULT:=m if ALL_KMODS
- KCONFIG:=CONFIG_PSTORE_RAM
+ KCONFIG:=CONFIG_PSTORE_RAM \
+ CONFIG_PSTORE_CONSOLE=y
DEPENDS:=+kmod-pstore +kmod-reed-solomon
FILES:= $(LINUX_DIR)/fs/pstore/ramoops.ko
AUTOLOAD:=$(call AutoLoad,30,ramoops,1)