summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
authorAnsuel Smith <ansuelsmth@gmail.com>2021-11-04 21:59:09 +0100
committerDaniel Golle <daniel@makrotopia.org>2022-03-27 02:17:24 +0100
commitbd0db6017b1921c935785cdccdf0243fddf0b949 (patch)
tree692a9e678f7b97b0ee6cf8ccc5021fbcaba15b24 /package/kernel/linux/modules/other.mk
parentb268ec5ff8baed74037d04a74f61c0417d931ad9 (diff)
downloadopenwrt-bd0db6017b1921c935785cdccdf0243fddf0b949.tar.gz
openwrt-bd0db6017b1921c935785cdccdf0243fddf0b949.tar.bz2
openwrt-bd0db6017b1921c935785cdccdf0243fddf0b949.zip
kernel: 5.15: add new module
Add new module require in 5.15 - Changes in block module - Changes in netfilter module (log module unified) - Changes in fs module (mainly new depends for cifs and new ntfs3 module) - Changes in lib add shared lib now used by more than 1 kmod - Changes in crypto, dropped one crypto algo added arm crypto accellerator - Changes in other, add zram default compressor choice and missing lib by tpm module Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk29
1 files changed, 26 insertions, 3 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index d343ff8d28..499a4080ea 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -959,7 +959,6 @@ $(eval $(call KernelPackage,ikconfig))
define KernelPackage/zram
SUBMENU:=$(OTHER_MENU)
TITLE:=ZRAM
- DEPENDS:=+kmod-lib-lzo
KCONFIG:= \
CONFIG_ZSMALLOC \
CONFIG_ZRAM \
@@ -976,8 +975,31 @@ define KernelPackage/zram/description
Compressed RAM block device support
endef
-$(eval $(call KernelPackage,zram))
+define KernelPackage/zram/config
+ choice
+ prompt "ZRAM Default compressor"
+ default ZRAM_DEF_COMP_LZORLE
+
+ config ZRAM_DEF_COMP_LZORLE
+ bool "lzo-rle"
+ select PACKAGE_kmod-lib-lzo
+
+ config ZRAM_DEF_COMP_LZO
+ bool "lzo"
+ select PACKAGE_kmod-lib-lzo
+
+ config ZRAM_DEF_COMP_LZ4
+ bool "lz4"
+ select PACKAGE_kmod-lib-lz4
+ config ZRAM_DEF_COMP_ZSTD
+ bool "zstd"
+ select PACKAGE_kmod-lib-zstd
+
+ endchoice
+endef
+
+$(eval $(call KernelPackage,zram))
define KernelPackage/pps
SUBMENU:=$(OTHER_MENU)
@@ -1190,7 +1212,8 @@ $(eval $(call KernelPackage,keys-trusted))
define KernelPackage/tpm
SUBMENU:=$(OTHER_MENU)
TITLE:=TPM Hardware Support
- DEPENDS:= +kmod-random-core
+ DEPENDS:= +kmod-random-core +(LINUX_5_15):kmod-asn1-decoder \
+ +(LINUX_5_15):kmod-asn1-encoder +(LINUX_5_15):kmod-oid-registry
KCONFIG:= CONFIG_TCG_TPM
FILES:= $(LINUX_DIR)/drivers/char/tpm/tpm.ko
AUTOLOAD:=$(call AutoLoad,10,tpm,1)