summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
authorBrian Norris <computersforpeace@gmail.com>2022-02-19 17:26:24 -0800
committerChristian Lamparter <chunkeey@gmail.com>2022-03-25 18:14:13 +0100
commite5b009e532813d73fe7d3e3deb77b4a60c364913 (patch)
tree65432779acd53ffdfff16e4b3751926fad5d2fb7 /package/kernel/linux/modules/other.mk
parente95dec811661f60ae931e09e320249187922bd67 (diff)
downloadopenwrt-e5b009e532813d73fe7d3e3deb77b4a60c364913.tar.gz
openwrt-e5b009e532813d73fe7d3e3deb77b4a60c364913.tar.bz2
openwrt-e5b009e532813d73fe7d3e3deb77b4a60c364913.zip
kernel: Package GOOGLE_FIRMWARE drivers
Useful for some Chromium OS based systems, like Google WiFi. Signed-off-by: Brian Norris <computersforpeace@gmail.com>
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk26
1 files changed, 26 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 5ccc860790..d343ff8d28 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -182,6 +182,32 @@ endef
$(eval $(call KernelPackage,eeprom-at25))
+define KernelPackage/google-firmware
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Google firmware drivers (Coreboot, VPD, Memconsole)
+ KCONFIG:= \
+ CONFIG_GOOGLE_FIRMWARE=y \
+ CONFIG_GOOGLE_COREBOOT_TABLE \
+ CONFIG_GOOGLE_MEMCONSOLE \
+ CONFIG_GOOGLE_MEMCONSOLE_COREBOOT \
+ CONFIG_GOOGLE_VPD
+ FILES:= \
+ $(LINUX_DIR)/drivers/firmware/google/coreboot_table.ko \
+ $(LINUX_DIR)/drivers/firmware/google/memconsole.ko \
+ $(LINUX_DIR)/drivers/firmware/google/memconsole-coreboot.ko \
+ $(LINUX_DIR)/drivers/firmware/google/vpd-sysfs.ko
+ AUTOLOAD:=$(call AutoProbe,coreboot_table memconsole-coreboot vpd-sysfs)
+endef
+
+define KernelPackage/google-firmware/description
+ Kernel modules for Google firmware drivers. Useful for examining firmware and
+ boot details on devices using a Google bootloader based on Coreboot. Provides
+ files like /sys/firmware/log and /sys/firmware/vpd.
+endef
+
+$(eval $(call KernelPackage,google-firmware))
+
+
define KernelPackage/gpio-f7188x
SUBMENU:=$(OTHER_MENU)
TITLE:=Fintek F718xx/F818xx GPIO Support