summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
authorÁlvaro Fernández Rojas <noltari@gmail.com>2023-04-20 09:58:03 +0200
committerÁlvaro Fernández Rojas <noltari@gmail.com>2023-04-23 12:18:35 +0200
commite656bcbab0106aca52ec0b2db354c1336d39b3b3 (patch)
tree57e42ce9c0e087cbd204eaaa26aeb852d8c54b12 /package/kernel/linux/modules/other.mk
parent876be833c7ba57aadd1ad8bbb81eba2fc6098098 (diff)
downloadopenwrt-e656bcbab0106aca52ec0b2db354c1336d39b3b3.tar.gz
openwrt-e656bcbab0106aca52ec0b2db354c1336d39b3b3.tar.bz2
openwrt-e656bcbab0106aca52ec0b2db354c1336d39b3b3.zip
kernel: add bcma/ssb fallback SPROM support
This adds generic kernel support for Broadcom Fallback SPROMs so that it can be used in any target, even non Broadcom ones. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 1369a4ad54..262aca4324 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -538,6 +538,7 @@ define KernelPackage/ssb
CONFIG_SSB_DRIVER_MIPS=n \
CONFIG_SSB_DRIVER_PCICORE=y \
CONFIG_SSB_DRIVER_PCICORE_POSSIBLE=y \
+ CONFIG_SSB_FALLBACK_SPROM=y \
CONFIG_SSB_PCIHOST=y \
CONFIG_SSB_PCIHOST_POSSIBLE=y \
CONFIG_SSB_POSSIBLE=y \
@@ -562,6 +563,7 @@ define KernelPackage/bcma
CONFIG_BCMA \
CONFIG_BCMA_POSSIBLE=y \
CONFIG_BCMA_BLOCKIO=y \
+ CONFIG_BCMA_FALLBACK_SPROM=y \
CONFIG_BCMA_HOST_PCI_POSSIBLE=y \
CONFIG_BCMA_HOST_PCI=y \
CONFIG_BCMA_HOST_SOC=n \