summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
authorLinus Walleij <linus.walleij@linaro.org>2024-02-23 08:23:47 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2024-02-29 23:01:38 +0100
commitef34f8f5b5606af4dbec64788ab014b4a627e00c (patch)
treee273502833a0064d5cf5aa55e75dd2bd3f42e78b /package/kernel/linux/modules/other.mk
parent09be63de70afdf7fe14a97c3bd6d65d650976fde (diff)
downloadopenwrt-ef34f8f5b5606af4dbec64788ab014b4a627e00c.tar.gz
openwrt-ef34f8f5b5606af4dbec64788ab014b4a627e00c.tar.bz2
openwrt-ef34f8f5b5606af4dbec64788ab014b4a627e00c.zip
kirkwood: Add Marvell RTC to all machines with nothing else
The Kirkwood SoCs all have an onchip RTC that can hold the time over e.g. a reboot which will help if no NTP servers are available. Create a kernel module package for the Marvell RTC, and add it to all Kirkwood devices that do not have their own discrete battery-backed RTC. Adding it to platforms with a proper RTC is just surplus. All Kirkwoods have at least one RTC so add RTC to the features list for Kirkwood as well. Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 4a061974c3..e227fd6a0f 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -578,6 +578,23 @@ endef
$(eval $(call KernelPackage,rtc-isl1208))
+define KernelPackage/rtc-mv
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Marvell SoC RTC support
+ DEFAULT:=m if ALL_KMODS && RTC_SUPPORT
+ KCONFIG:=CONFIG_RTC_DRV_MV \
+ CONFIG_RTC_CLASS=y
+ FILES:=$(LINUX_DIR)/drivers/rtc/rtc-mv.ko
+ AUTOLOAD:=$(call AutoProbe,rtc-mv)
+endef
+
+define KernelPackage/rtc-mv/description
+ Kernel module for Marvell SoC RTC.
+endef
+
+$(eval $(call KernelPackage,rtc-mv))
+
+
define KernelPackage/rtc-pcf8563
SUBMENU:=$(OTHER_MENU)
TITLE:=Philips PCF8563/Epson RTC8564 RTC support