summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
authorWeijie Gao <hackpascal@gmail.com>2024-01-06 15:08:41 +0800
committerRobert Marko <robimarko@gmail.com>2024-03-11 20:17:26 +0100
commit0c98d99c5e8178ee8e578e67afa7bee7da9e4a14 (patch)
tree40736e2e3e311f444d78e18dd1a42987cd58da5f /package/kernel/linux
parent8d83b9ee2dd4e22a1bf08d117c9b508ff5c66709 (diff)
downloadopenwrt-0c98d99c5e8178ee8e578e67afa7bee7da9e4a14.tar.gz
openwrt-0c98d99c5e8178ee8e578e67afa7bee7da9e4a14.tar.bz2
openwrt-0c98d99c5e8178ee8e578e67afa7bee7da9e4a14.zip
kernel: modules: input: adapt for kernel 6.6
Adapt input kmods for building under kernel 6.6: * kmod-input-touchscreen-edt-ft5x06 depends on kmod-regmap-i2c from 6.3 as it starts to use regmap to access registers * CONFIG_HID_SUPPORT needs to be set in addition to CONFIG_HID. Signed-off-by: Daniel Golle <daniel@makrotopia.org> Signed-off-by: Weijie Gao <hackpascal@gmail.com>
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/input.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/input.mk b/package/kernel/linux/modules/input.mk
index 92587b1874..89fba29005 100644
--- a/package/kernel/linux/modules/input.mk
+++ b/package/kernel/linux/modules/input.mk
@@ -11,7 +11,7 @@ define KernelPackage/hid
SUBMENU:=$(INPUT_MODULES_MENU)
TITLE:=HID Devices
DEPENDS:=+kmod-input-core +kmod-input-evdev
- KCONFIG:=CONFIG_HID CONFIG_HIDRAW=y CONFIG_HID_BATTERY_STRENGTH=y
+ KCONFIG:=CONFIG_HID CONFIG_HID_SUPPORT=y CONFIG_HIDRAW=y CONFIG_HID_BATTERY_STRENGTH=y
FILES:=$(LINUX_DIR)/drivers/hid/hid.ko
AUTOLOAD:=$(call AutoLoad,61,hid)
endef
@@ -179,7 +179,7 @@ $(eval $(call KernelPackage,input-touchscreen-ads7846))
define KernelPackage/input-touchscreen-edt-ft5x06
SUBMENU:=$(INPUT_MODULES_MENU)
TITLE:=EDT FT5x06 and Focaltech FT6236 based touchscreens
- DEPENDS:=+kmod-i2c-core +kmod-input-core
+ DEPENDS:=+kmod-i2c-core +kmod-input-core +LINUX_6_6:kmod-regmap-i2c
KCONFIG:= \
CONFIG_INPUT_TOUCHSCREEN=y \
CONFIG_TOUCHSCREEN_EDT_FT5X06