summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-03-27 13:39:49 -0700
committerChristian Lamparter <chunkeey@gmail.com>2019-04-06 19:14:06 +0200
commit2a8175a7ac79f37444eed1dc72054e170c71491e (patch)
tree9d7075edf753028603f550fa1b0cf11d1859cdb0 /package/kernel/linux
parentb19c48dc34fce44445b8ad0027220d63870fd280 (diff)
downloadopenwrt-2a8175a7ac79f37444eed1dc72054e170c71491e.tar.gz
openwrt-2a8175a7ac79f37444eed1dc72054e170c71491e.tar.bz2
openwrt-2a8175a7ac79f37444eed1dc72054e170c71491e.zip
kernel: Add RIPEMD160 module
After getting rid of cryptsetup's heavy openssl dependency, there is now the problem of missing RIPEMD160 support. RIPEMD160 is used for True/Vera crypt volumes as well as old LUKS1 ones. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/crypto.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index 1add16e161..fef9ea0ebf 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -597,6 +597,18 @@ endef
$(eval $(call KernelPackage,crypto-rsa))
+define KernelPackage/crypto-rmd160
+ TITLE:=RIPEMD160 digest CryptoAPI module
+ DEPENDS:=+kmod-crypto-hash
+ KCONFIG:=CONFIG_CRYPTO_RMD160
+ FILES:=$(LINUX_DIR)/crypto/rmd160.ko
+ AUTOLOAD:=$(call AutoLoad,09,rmd160)
+ $(call AddDepends/crypto)
+endef
+
+$(eval $(call KernelPackage,crypto-rmd160))
+
+
define KernelPackage/crypto-rng
TITLE:=CryptoAPI random number generation
DEPENDS:=+kmod-crypto-hash +kmod-crypto-hmac +kmod-crypto-sha256