summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2024-06-29 18:14:47 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2024-07-03 13:11:01 +0200
commit2ebeda029490e308cc0e8f475e63280f960e74c4 (patch)
tree1a2230934bdffdf8745e1c383ea6e2b09efef4db /package/kernel/linux
parentf89091bba6be483e66c5ac14c477621f74aef203 (diff)
downloadopenwrt-2ebeda029490e308cc0e8f475e63280f960e74c4.tar.gz
openwrt-2ebeda029490e308cc0e8f475e63280f960e74c4.tar.bz2
openwrt-2ebeda029490e308cc0e8f475e63280f960e74c4.zip
kernel: Add kmod-crypto-xxhash
kxxhash_generic.ko is a soft dependency of kmod-fs-btrfs, but we did not package it. Extract the kmod-lib-xxhash and then package xxhash_generic.ko. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> Link: https://github.com/openwrt/openwrt/pull/15833 Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/crypto.mk12
-rw-r--r--package/kernel/linux/modules/fs.mk2
-rw-r--r--package/kernel/linux/modules/lib.mk19
3 files changed, 27 insertions, 6 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index c2f8bf716d..43330bf064 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -1170,3 +1170,15 @@ endef
$(eval $(call KernelPackage,crypto-xts))
+
+define KernelPackage/crypto-xxhash
+ TITLE:=xxHash non-cryptographic hash algorithm
+ DEPENDS:=+kmod-crypto-hash +kmod-lib-xxhash
+ KCONFIG:=CONFIG_CRYPTO_XXHASH
+ FILES:=$(LINUX_DIR)/crypto/xxhash_generic.ko
+ AUTOLOAD:=$(call AutoLoad,09,xxhash_generic)
+ $(call AddDepends/crypto)
+endef
+
+$(eval $(call KernelPackage,crypto-xxhash))
+
diff --git a/package/kernel/linux/modules/fs.mk b/package/kernel/linux/modules/fs.mk
index 82d1cd6f78..bc55dbd967 100644
--- a/package/kernel/linux/modules/fs.mk
+++ b/package/kernel/linux/modules/fs.mk
@@ -67,7 +67,7 @@ $(eval $(call KernelPackage,fs-autofs4))
define KernelPackage/fs-btrfs
SUBMENU:=$(FS_MENU)
TITLE:=BTRFS filesystem support
- DEPENDS:=+kmod-lib-crc32c +kmod-lib-lzo +kmod-lib-zlib-inflate +kmod-lib-zlib-deflate +kmod-lib-raid6 +kmod-lib-xor +kmod-lib-zstd +kmod-crypto-blake2b
+ DEPENDS:=+kmod-lib-crc32c +kmod-lib-lzo +kmod-lib-zlib-inflate +kmod-lib-zlib-deflate +kmod-lib-raid6 +kmod-lib-xor +kmod-lib-zstd +kmod-crypto-blake2b +kmod-crypto-xxhash
KCONFIG:=\
CONFIG_BTRFS_FS \
CONFIG_BTRFS_FS_CHECK_INTEGRITY=n
diff --git a/package/kernel/linux/modules/lib.mk b/package/kernel/linux/modules/lib.mk
index 820c569741..ea4f034b99 100644
--- a/package/kernel/linux/modules/lib.mk
+++ b/package/kernel/linux/modules/lib.mk
@@ -122,22 +122,31 @@ endef
$(eval $(call KernelPackage,lib-lzo))
+define KernelPackage/lib-xxhash
+ SUBMENU:=$(LIB_MENU)
+ TITLE:=xxhash support
+ HIDDEN:=1
+ KCONFIG:=CONFIG_XXHASH
+ FILES:=$(LINUX_DIR)/lib/xxhash.ko
+endef
+
+$(eval $(call KernelPackage,lib-xxhash))
+
+
define KernelPackage/lib-zstd
SUBMENU:=$(LIB_MENU)
TITLE:=ZSTD support
- DEPENDS:=+kmod-crypto-acompress
+ DEPENDS:=+kmod-crypto-acompress +kmod-lib-xxhash
KCONFIG:= \
CONFIG_CRYPTO_ZSTD \
CONFIG_ZSTD_COMPRESS \
- CONFIG_ZSTD_DECOMPRESS \
- CONFIG_XXHASH
+ CONFIG_ZSTD_DECOMPRESS
FILES:= \
$(LINUX_DIR)/crypto/zstd.ko \
- $(LINUX_DIR)/lib/xxhash.ko \
$(LINUX_DIR)/lib/zstd/zstd_common.ko@ge6.1 \
$(LINUX_DIR)/lib/zstd/zstd_compress.ko \
$(LINUX_DIR)/lib/zstd/zstd_decompress.ko
- AUTOLOAD:=$(call AutoProbe,xxhash zstd zstd_compress zstd_decompress)
+ AUTOLOAD:=$(call AutoProbe,zstd zstd_compress zstd_decompress)
endef
define KernelPackage/lib-zstd/description