summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
authorKoen Vandeputte <koen.vandeputte@ncentric.com>2019-03-27 16:46:39 +0100
committerKoen Vandeputte <koen.vandeputte@ncentric.com>2019-03-27 16:46:39 +0100
commit555ee02f77db470b2903b55a154e8532cfe7a4c7 (patch)
tree0b0b91a953e5e3f835e0d0232b1f31ff9f1897c7 /package/kernel/linux
parentb65a270c851ee422f26a0af10c879ebb87cb8f76 (diff)
downloadopenwrt-555ee02f77db470b2903b55a154e8532cfe7a4c7.tar.gz
openwrt-555ee02f77db470b2903b55a154e8532cfe7a4c7.tar.bz2
openwrt-555ee02f77db470b2903b55a154e8532cfe7a4c7.zip
kernel: fix missing dependency in 4.14.108
The 4.14.108 bump introduced a missing dependency when building specific netfilters. Thsi was not seen as the error does not occur on all targets. Thanks to Jo-Philipp Wich for providing the fix Fixes: af6c86dbe56e ("kernel: bump 4.14 to 4.14.108") Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/netfilter.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/netfilter.mk b/package/kernel/linux/modules/netfilter.mk
index 6c78394297..dc3cdb6531 100644
--- a/package/kernel/linux/modules/netfilter.mk
+++ b/package/kernel/linux/modules/netfilter.mk
@@ -368,7 +368,7 @@ IPVS_MODULES:= \
define KernelPackage/nf-ipvs
SUBMENU:=Netfilter Extensions
TITLE:=IP Virtual Server modules
- DEPENDS:=@IPV6 +kmod-lib-crc32c +kmod-ipt-conntrack +kmod-nf-conntrack
+ DEPENDS:=@IPV6 +kmod-lib-crc32c +kmod-ipt-conntrack +kmod-nf-conntrack +LINUX_4_14:kmod-nf-conntrack6
KCONFIG:= \
CONFIG_IP_VS \
CONFIG_IP_VS_IPV6=y \