summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
authorNathaniel Wesley Filardo <nwfilardo@gmail.com>2024-06-20 15:15:41 +0100
committerRobert Marko <robimarko@gmail.com>2024-06-23 14:07:17 +0200
commit98793e02f7e2f4e212edb12dcedd1afe62802dce (patch)
treea2e06e3d3185158fddcd7b04cb08b347d618ae46 /package/kernel/linux
parent0ed72c271b13078d2daff45349368ed80d4a1fd5 (diff)
downloadopenwrt-98793e02f7e2f4e212edb12dcedd1afe62802dce.tar.gz
openwrt-98793e02f7e2f4e212edb12dcedd1afe62802dce.tar.bz2
openwrt-98793e02f7e2f4e212edb12dcedd1afe62802dce.zip
kernel: catch up rxrpc
New dependencies required for the module to be useful, and correct IPv6 support Signed-off-by: Nathaniel Wesley Filardo <nwfilardo@gmail.com> Link: https://github.com/openwrt/openwrt/pull/15761 Signed-off-by: Robert Marko <robimarko@gmail.com>
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/netsupport.mk15
1 files changed, 11 insertions, 4 deletions
diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
index 0ee58fada4..e56defad38 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -1297,13 +1297,20 @@ define KernelPackage/rxrpc
HIDDEN:=1
KCONFIG:= \
CONFIG_AF_RXRPC \
- CONFIG_RXKAD=m \
+ CONFIG_AF_RXRPC_IPV6=y \
+ CONFIG_RXKAD \
CONFIG_AF_RXRPC_DEBUG=n
FILES:= \
$(LINUX_DIR)/net/rxrpc/rxrpc.ko
- AUTOLOAD:=$(call AutoLoad,30,rxrpc.ko)
- DEPENDS:= +kmod-crypto-manager +kmod-crypto-pcbc +kmod-crypto-fcrypt \
- +kmod-udptunnel4 +kmod-udptunnel6
+ AUTOLOAD:=$(call AutoLoad,30,rxrpc)
+ DEPENDS:= \
+ +kmod-crypto-fcrypt \
+ +kmod-crypto-hmac \
+ +kmod-crypto-manager \
+ +kmod-crypto-md5 \
+ +kmod-crypto-pcbc \
+ +kmod-udptunnel4 \
+ +IPV6:kmod-udptunnel6
endef
define KernelPackage/rxrpc/description