summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2024-03-02 04:21:29 +0000
committerRobert Marko <robimarko@gmail.com>2024-03-11 20:17:26 +0100
commitad2906b40573b35d01d5de636fd41edcc9b6a26d (patch)
tree947b3151eeb331c42bebeb275cd1b66a359eb553 /package/kernel/linux
parent48b52d51dcb976a57875435786562987d5b8d2f7 (diff)
downloadopenwrt-ad2906b40573b35d01d5de636fd41edcc9b6a26d.tar.gz
openwrt-ad2906b40573b35d01d5de636fd41edcc9b6a26d.tar.bz2
openwrt-ad2906b40573b35d01d5de636fd41edcc9b6a26d.zip
kernel: modules: netdevices: adapt for kernel 6.6
Adapt netdevices kmods for building under kernel 6.6: * Add missing module dependency for kmod-stmmac-core on kmod-of-mdio. * Invert criteria to allow Airoha EN8811H PHY driver to build with Linux 6.1 as well as Linux 6.6. * Mellanox mlx5 driver started exposing thermal sensors and now it requires hwmon Signed-off-by: Robert Marko <robimarko@gmail.com> Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/netdevices.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/kernel/linux/modules/netdevices.mk b/package/kernel/linux/modules/netdevices.mk
index 72504d8de7..d43866ed9b 100644
--- a/package/kernel/linux/modules/netdevices.mk
+++ b/package/kernel/linux/modules/netdevices.mk
@@ -378,7 +378,7 @@ $(eval $(call KernelPackage,phy-smsc))
define KernelPackage/phy-airoha-en8811h
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=Airoha EN8811H 2.5G Ethernet PHY
- DEPENDS:=+airoha-en8811h-firmware +kmod-libphy @LINUX_6_1
+ DEPENDS:=+airoha-en8811h-firmware +kmod-libphy @!LINUX_5_15
KCONFIG:=CONFIG_AIR_EN8811H_PHY
FILES:= \
$(LINUX_DIR)/drivers/net/phy/air_en8811h.ko
@@ -1360,7 +1360,7 @@ $(eval $(call KernelPackage,mlx4-core))
define KernelPackage/mlx5-core
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=Mellanox ConnectX(R) mlx5 core Network Driver
- DEPENDS:=@PCI_SUPPORT +kmod-ptp +kmod-mlxfw
+ DEPENDS:=@PCI_SUPPORT +kmod-ptp +kmod-mlxfw +LINUX_6_6:kmod-hwmon-core
FILES:=$(LINUX_DIR)/drivers/net/ethernet/mellanox/mlx5/core/mlx5_core.ko
KCONFIG:= CONFIG_MLX5_CORE \
CONFIG_MLX5_CORE_EN=y \
@@ -1573,7 +1573,7 @@ $(eval $(call KernelPackage,pcs-xpcs))
define KernelPackage/stmmac-core
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=Synopsis Ethernet Controller core (NXP,STMMicro,others)
- DEPENDS:=@TARGET_x86_64||TARGET_armsr_armv8 +kmod-pcs-xpcs +kmod-ptp
+ DEPENDS:=@TARGET_x86_64||TARGET_armsr_armv8 +kmod-pcs-xpcs +LINUX_6_6:kmod-of-mdio +kmod-ptp
KCONFIG:=CONFIG_STMMAC_ETH \
CONFIG_STMMAC_SELFTESTS=n \
CONFIG_STMMAC_PLATFORM \