summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2019-06-20 08:22:44 +0000
committerYousong Zhou <yszhou4tech@gmail.com>2019-06-20 08:24:20 +0000
commitf528d771c424abe81859bcccd084bfe8430f568e (patch)
treead00d8379f2e3c2faf4ff6000dcaa570d9e3ef69 /package/kernel/linux
parent62abbd587dc9a6c6ea8e46da9a1352b8bdc8cfd5 (diff)
downloadopenwrt-f528d771c424abe81859bcccd084bfe8430f568e.tar.gz
openwrt-f528d771c424abe81859bcccd084bfe8430f568e.tar.bz2
openwrt-f528d771c424abe81859bcccd084bfe8430f568e.zip
netsupport: add kmod-nsh
This is required by kmod-openvswitch since linux 4.15. Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/netsupport.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
index 9732ee0d73..6bd1f33979 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -128,6 +128,23 @@ endef
$(eval $(call KernelPackage,geneve))
+define KernelPackage/nsh
+ SUBMENU:=$(NETWORK_SUPPORT_MENU)
+ TITLE:=Network Service Header (NSH) protocol
+ DEPENDS:=
+ KCONFIG:=CONFIG_NET_NSH
+ FILES:=$(LINUX_DIR)/net/nsh/nsh.ko@ge4.14
+ AUTOLOAD:=$(call AutoLoad,13,nsh)
+endef
+
+define KernelPackage/nsh/description
+ Network Service Header is an implementation of Service Function
+ Chaining (RFC 7665). Requires kernel 4.14 or newer
+endef
+
+$(eval $(call KernelPackage,nsh))
+
+
define KernelPackage/capi
SUBMENU:=$(NETWORK_SUPPORT_MENU)
TITLE:=CAPI (ISDN) Support