summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
authorTan Zien <nabsdh9@gmail.com>2024-03-04 00:57:03 +0800
committerRobert Marko <robimarko@gmail.com>2024-03-11 20:17:26 +0100
commitfaf3d80bf1751e457af73fa22f2d2f3517f2d93f (patch)
treec7d2a0c7c5efe0c5314da2dc48531b4787750c78 /package/kernel/linux
parent35b04bafa187a99044ced7df9eb9148bc771be64 (diff)
downloadopenwrt-faf3d80bf1751e457af73fa22f2d2f3517f2d93f.tar.gz
openwrt-faf3d80bf1751e457af73fa22f2d2f3517f2d93f.tar.bz2
openwrt-faf3d80bf1751e457af73fa22f2d2f3517f2d93f.zip
kernel: modules: hwmon: adapt for kernel 6.6
Adapt hwmon kmods for building under kernel 6.6: * ad7418 now requires regmap * Invert criteria to allow adt7410 be built with Linux 6.1 as well as Linux 6.6. Signed-off-by: Tan Zien <nabsdh9@gmail.com>
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/hwmon.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/hwmon.mk b/package/kernel/linux/modules/hwmon.mk
index 8afe315344..0d105dcc9e 100644
--- a/package/kernel/linux/modules/hwmon.mk
+++ b/package/kernel/linux/modules/hwmon.mk
@@ -34,7 +34,7 @@ define KernelPackage/hwmon-ad7418
KCONFIG:=CONFIG_SENSORS_AD7418
FILES:=$(LINUX_DIR)/drivers/hwmon/ad7418.ko
AUTOLOAD:=$(call AutoLoad,60,ad7418 ad7418)
- $(call AddDepends/hwmon,+kmod-i2c-core)
+ $(call AddDepends/hwmon,+kmod-i2c-core +LINUX_6_6:kmod-regmap-core)
endef
define KernelPackage/hwmon-ad7418/description
@@ -52,7 +52,7 @@ define KernelPackage/hwmon-adt7410
$(LINUX_DIR)/drivers/hwmon/adt7x10.ko \
$(LINUX_DIR)/drivers/hwmon/adt7410.ko
AUTOLOAD:=$(call AutoLoad,60,adt7x10 adt7410)
- $(call AddDepends/hwmon,+kmod-i2c-core +LINUX_6_1:kmod-regmap-core)
+ $(call AddDepends/hwmon,+kmod-i2c-core +!LINUX_5_15:kmod-regmap-core)
endef
define KernelPackage/hwmon-adt7410/description