summaryrefslogtreecommitdiffstats
path: root/package/kernel/mac80211/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2022-10-12 12:54:30 +0200
committerFelix Fietkau <nbd@nbd.name>2022-11-09 20:44:28 +0100
commita06e023b4e124dad2b2ddf3db87cb804b7043b26 (patch)
tree64a3dfcbc4ae2692c2670f37392e7955dc5d8c56 /package/kernel/mac80211/Makefile
parentf753316f4aa4764e80c4dbf6f2cc88922052da1e (diff)
downloadopenwrt-a06e023b4e124dad2b2ddf3db87cb804b7043b26.tar.gz
openwrt-a06e023b4e124dad2b2ddf3db87cb804b7043b26.tar.bz2
openwrt-a06e023b4e124dad2b2ddf3db87cb804b7043b26.zip
mac80211: remove old legacy legacy drivers
Get rid of drivers that are either limited to 802.11b/g or don't even support cfg80211/mac80211. Most of these are either limited to boards that we don't even support anymore because of firmware size, or were only used for custom hacks by a really small number of users in the past. Let's get rid of those to reduce the maintenance effort and the number of useless packages Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/kernel/mac80211/Makefile')
-rw-r--r--package/kernel/mac80211/Makefile167
1 files changed, 2 insertions, 165 deletions
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index 91dad18254..ec35bf67ec 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -22,15 +22,10 @@ PKG_BUILD_PARALLEL:=1
PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
PKG_DRIVERS = \
- adm8211 \
- hermes hermes-pci hermes-pcmcia hermes-plx\
- lib80211 \
mac80211-hwsim \
mt7601u \
- p54-common p54-pci p54-usb \
rsi91x rsi91x-usb rsi91x-sdio\
- wlcore wl12xx wl18xx \
- zd1211rw
+ wlcore wl12xx wl18xx
PKG_CONFIG_DEPENDS:= \
CONFIG_PACKAGE_kmod-mac80211 \
@@ -164,92 +159,6 @@ define KernelPackage/mac80211/description
Generic IEEE 802.11 Networking Stack (mac80211)
endef
-define KernelPackage/adm8211
- $(call KernelPackage/mac80211/Default)
- TITLE:=ADMTek 8211 support
- DEPENDS+=@PCI_SUPPORT +kmod-mac80211 +kmod-eeprom-93cx6
- FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/admtek/adm8211.ko
- AUTOLOAD:=$(call AutoProbe,adm8211)
-endef
-
-define KernelPackage/hermes
- $(call KernelPackage/mac80211/Default)
- TITLE:=Hermes 802.11b chipset support
- DEPENDS:=@PCI_SUPPORT||PCMCIA_SUPPORT +kmod-cfg80211 +@DRIVER_WEXT_SUPPORT +kmod-crypto-michael-mic
- DEFAULT:=n
- FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/intersil/orinoco/orinoco.ko
- AUTOLOAD:=$(call AutoProbe,orinoco)
-endef
-
-define KernelPackage/hermes/description
- Kernel support for Hermes 802.11b chipsets
-endef
-
-define KernelPackage/hermes-pci
- $(call KernelPackage/mac80211/Default)
- TITLE:=Intersil Prism 2.5 PCI support
- DEPENDS:=@PCI_SUPPORT +kmod-hermes
- FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/intersil/orinoco/orinoco_pci.ko
- AUTOLOAD:=$(call AutoProbe,orinoco_pci)
-endef
-
-define KernelPackage/hermes-pci/description
- Kernel modules for Intersil Prism 2.5 PCI support
-endef
-
-define KernelPackage/hermes-plx
- $(call KernelPackage/mac80211/Default)
- TITLE:=PLX9052 based PCI adaptor
- DEPENDS:=@PCI_SUPPORT +kmod-hermes
- FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/intersil/orinoco/orinoco_plx.ko
- AUTOLOAD:=$(call AutoProbe,orinoco_plx)
-endef
-
-define KernelPackage/hermes-plx/description
- Kernel modules for Hermes in PLX9052 based PCI adaptors
-endef
-
-define KernelPackage/hermes-pcmcia
- $(call KernelPackage/mac80211/Default)
- TITLE:=Hermes based PCMCIA adaptors
- DEPENDS:=@PCMCIA_SUPPORT +kmod-hermes +kmod-pcmcia-core
- FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/intersil/orinoco/orinoco_cs.ko
- AUTOLOAD:=$(call AutoProbe,orinoco_cs)
-endef
-
-define KernelPackage/hermes-pcmcia/description
- Kernel modules for Hermes based PCMCIA adaptors
-endef
-
-
-define KernelPackage/lib80211
- $(call KernelPackage/mac80211/Default)
- TITLE:=802.11 Networking stack
- DEPENDS:=+kmod-cfg80211 +kmod-crypto-hash +kmod-crypto-ccm
- HIDDEN:=1
- FILES:= \
- $(PKG_BUILD_DIR)/net/wireless/lib80211.ko \
- $(PKG_BUILD_DIR)/net/wireless/lib80211_crypt_wep.ko \
- $(PKG_BUILD_DIR)/net/wireless/lib80211_crypt_ccmp.ko \
- $(PKG_BUILD_DIR)/net/wireless/lib80211_crypt_tkip.ko
- AUTOLOAD:=$(call AutoProbe, \
- lib80211 \
- lib80211_crypt_wep \
- lib80211_crypt_ccmp \
- lib80211_crypt_tkip \
- )
-endef
-
-define KernelPackage/lib80211/description
- Kernel modules for 802.11 Networking stack
- Includes:
- - lib80211
- - lib80211_crypt_wep
- - lib80211_crypt_tkip
- - lib80211_crytp_ccmp
-endef
-
-
define KernelPackage/mac80211-hwsim
$(call KernelPackage/mac80211/Default)
TITLE:=mac80211 HW simulation device
@@ -267,38 +176,6 @@ define KernelPackage/mt7601u
AUTOLOAD:=$(call AutoProbe,mt7601u)
endef
-define KernelPackage/p54/Default
- $(call KernelPackage/mac80211/Default)
- TITLE:=Prism54 Drivers
-endef
-
-define KernelPackage/p54/description
- Kernel module for Prism54 chipsets (mac80211)
-endef
-
-define KernelPackage/p54-common
- $(call KernelPackage/p54/Default)
- DEPENDS+= @(PCI_SUPPORT||USB_SUPPORT) +kmod-mac80211 +kmod-lib-crc-ccitt
- TITLE+= (COMMON)
- FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/intersil/p54/p54common.ko
-endef
-
-define KernelPackage/p54-pci
- $(call KernelPackage/p54/Default)
- TITLE+= (PCI)
- DEPENDS+= @PCI_SUPPORT +kmod-p54-common +p54-pci-firmware
- FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/intersil/p54/p54pci.ko
- AUTOLOAD:=$(call AutoProbe,p54pci)
-endef
-
-define KernelPackage/p54-usb
- $(call KernelPackage/p54/Default)
- TITLE+= (USB)
- DEPENDS+= @USB_SUPPORT +kmod-usb-core +kmod-p54-common +p54-usb-firmware
- FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/intersil/p54/p54usb.ko
- AUTOLOAD:=$(call AutoProbe,p54usb)
-endef
-
define KernelPackage/rsi91x
$(call KernelPackage/mac80211/Default)
TITLE:=Redpine Signals Inc 91x WLAN driver support
@@ -364,23 +241,6 @@ define KernelPackage/wl18xx/description
endef
-ZD1211FW_NAME:=zd1211-firmware
-ZD1211FW_VERSION:=1.4
-define Download/zd1211rw
- FILE:=$(ZD1211FW_NAME)-$(ZD1211FW_VERSION).tar.bz2
- URL:=@SF/zd1211/
- HASH:=866308f6f59f7075f075d4959dff2ede47735c751251fecd1496df1ba4d338e1
-endef
-$(eval $(call Download,zd1211rw))
-
-define KernelPackage/zd1211rw
- $(call KernelPackage/mac80211/Default)
- TITLE:=Zydas ZD1211 support
- DEPENDS+= @USB_SUPPORT +kmod-usb-core +kmod-mac80211
- FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/zydas/zd1211rw/zd1211rw.ko
- AUTOLOAD:=$(call AutoProbe,zd1211rw)
-endef
-
ifdef CONFIG_PACKAGE_MAC80211_DEBUGFS
config-y += \
CFG80211_DEBUGFS \
@@ -392,28 +252,14 @@ ifdef CONFIG_PACKAGE_MAC80211_TRACING
IWLWIFI_DEVICE_TRACING
endif
-config-$(call config_package,lib80211) += LIB80211 LIB80211_CRYPT_WEP LIB80211_CRYPT_CCMP LIB80211_CRYPT_TKIP
-
config-$(call config_package,mac80211-hwsim) += MAC80211_HWSIM
config-$(call config_package,mt7601u) += MT7601U
config-y += WL_MEDIATEK
-config-$(call config_package,p54-common) += P54_COMMON
-config-$(call config_package,p54-pci) += P54_PCI
-config-$(call config_package,p54-usb) += P54_USB
-
-config-$(call config_package,hermes) += HERMES
-config-$(call config_package,hermes-pci) += PCI_HERMES
-config-$(call config_package,hermes-plx) += PLX_HERMES
-config-$(call config_package,hermes-pcmcia) += PCMCIA_HERMES
-config-y += HERMES_PRISM
-
-config-$(call config_package,adm8211) += ADM8211
config-$(call config_package,wlcore) += WLCORE WLCORE_SDIO
config-$(call config_package,wl12xx) += WL12XX
config-$(call config_package,wl18xx) += WL18XX
config-y += WL_TI WILINK_PLATFORM_DATA
-config-$(call config_package,zd1211rw) += ZD1211RW
config-$(call config_package,rsi91x) += RSI_91X
config-$(call config_package,rsi91x-usb) += RSI_USB
config-$(call config_package,rsi91x-sdio) += RSI_SDIO
@@ -450,9 +296,6 @@ define Build/Prepare
mkdir -p $(PKG_BUILD_DIR)
$(PKG_UNPACK)
$(Build/Patch)
- $(TAR) -C $(PKG_BUILD_DIR) -xzf $(DL_DIR)/$(IPW2100_NAME)-$(IPW2100_VERSION).tgz
- $(TAR) -C $(PKG_BUILD_DIR) -xzf $(DL_DIR)/$(IPW2200_NAME)-$(IPW2200_VERSION).tgz
- $(TAR) -C $(PKG_BUILD_DIR) -xjf $(DL_DIR)/$(ZD1211FW_NAME)-$(ZD1211FW_VERSION).tar.bz2
rm -rf \
$(PKG_BUILD_DIR)/include/linux/ssb \
$(PKG_BUILD_DIR)/include/linux/bcma \
@@ -463,14 +306,13 @@ define Build/Prepare
$(PKG_BUILD_DIR)/include/linux/crc8.h \
$(PKG_BUILD_DIR)/include/linux/eeprom_93cx6.h \
$(PKG_BUILD_DIR)/include/linux/wl12xx.h \
- $(PKG_BUILD_DIR)/include/linux/spi/libertas_spi.h \
$(PKG_BUILD_DIR)/include/net/ieee80211.h \
$(PKG_BUILD_DIR)/backport-include/linux/bcm47xx_nvram.h
echo 'compat-wireless-$(PKG_VERSION)-$(PKG_RELEASE)-$(REVISION)' > $(PKG_BUILD_DIR)/compat_version
endef
-ifneq ($(CONFIG_PACKAGE_kmod-cfg80211)$(CONFIG_PACKAGE_kmod-lib80211),)
+ifneq ($(CONFIG_PACKAGE_kmod-cfg80211),)
define Build/Compile/kmod
rm -rf $(PKG_BUILD_DIR)/modules
+$(MAKE) $(PKG_JOBS) $(MAKE_OPTS) modules
@@ -546,11 +388,6 @@ define KernelPackage/cfg80211/install
$(INSTALL_DATA) ./files/mac80211.hotplug $(1)/etc/hotplug.d/ieee80211/10-wifi-detect
endef
-define KernelPackage/zd1211rw/install
- $(INSTALL_DIR) $(1)/lib/firmware/zd1211
- $(INSTALL_DATA) $(PKG_BUILD_DIR)/$(ZD1211FW_NAME)/zd1211* $(1)/lib/firmware/zd1211
-endef
-
$(eval $(foreach drv,$(PKG_DRIVERS),$(call KernelPackage,$(drv))))
$(eval $(call KernelPackage,cfg80211))
$(eval $(call KernelPackage,mac80211))