summaryrefslogtreecommitdiffstats
path: root/package/libs/libjson-c/Makefile
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2018-06-14 20:09:29 +0200
committerDaniel Golle <daniel@makrotopia.org>2018-06-14 20:09:29 +0200
commit6fc8e06078d30e8d36a00d0ecc97ac9cc148fe60 (patch)
tree9a63e314d29eb2a16f3ae8641a5c8652fff36007 /package/libs/libjson-c/Makefile
parent1b8f3d9c2ec3dd89dda524c37e4d69c3d213918e (diff)
downloadopenwrt-6fc8e06078d30e8d36a00d0ecc97ac9cc148fe60.tar.gz
openwrt-6fc8e06078d30e8d36a00d0ecc97ac9cc148fe60.tar.bz2
openwrt-6fc8e06078d30e8d36a00d0ecc97ac9cc148fe60.zip
libjson-c: add host build (for libblobmsg-json)
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'package/libs/libjson-c/Makefile')
-rw-r--r--package/libs/libjson-c/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/libs/libjson-c/Makefile b/package/libs/libjson-c/Makefile
index eeb7870f07..60b51146af 100644
--- a/package/libs/libjson-c/Makefile
+++ b/package/libs/libjson-c/Makefile
@@ -27,6 +27,7 @@ PKG_INSTALL:=1
PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/host-build.mk
TARGET_CFLAGS += $(FPIC) -Wno-implicit-fallthrough
@@ -56,3 +57,4 @@ define Package/libjson-c/install
endef
$(eval $(call BuildPackage,libjson-c))
+$(eval $(call HostBuild))