summaryrefslogtreecommitdiffstats
path: root/package/libs/libjson-c/Makefile
diff options
context:
space:
mode:
authorNick Hainke <vincent@systemli.org>2022-06-27 15:11:47 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2022-07-03 20:25:38 +0200
commitf3a198697f6015ee47780841f0418d0d27f1c9c4 (patch)
treef18b7f8ae2b11a7b3f14cb3ad191321547a65a29 /package/libs/libjson-c/Makefile
parentb32f1650480b08b39a75e9b0da2a3517955ebb56 (diff)
downloadopenwrt-f3a198697f6015ee47780841f0418d0d27f1c9c4.tar.gz
openwrt-f3a198697f6015ee47780841f0418d0d27f1c9c4.tar.bz2
openwrt-f3a198697f6015ee47780841f0418d0d27f1c9c4.zip
libjson-c: update to 0.16
Fix: - 001-dont-build-docs.patch Remove upstreamed patch: - 010-clang.patch Changelog: Deprecated and removed features: -------------------------------- * JSON_C_OBJECT_KEY_IS_CONSTANT is deprecated in favor of JSON_C_OBJECT_ADD_CONSTANT_KEY * Direct access to lh_table and lh_entry structure members is deprecated. Use access functions instead, lh_table_head(), lh_entry_next(), etc... * Drop REFCOUNT_DEBUG code. New features ------------ * The 0.16 release introduces no new features Build changes ------------- * Add a DISABLE_EXTRA_LIBS option to skip using libbsd * Add a DISABLE_JSON_POINTER option to skip compiling in json_pointer support. Significant changes and bug fixes --------------------------------- * Cap string length at INT_MAX to avoid various issues with very long strings. * json_object_deep_copy: fix deep copy of strings containing '\0' * Fix read past end of buffer in the "json_parse" command * Avoid out of memory accesses in the locally provided vasprintf() function (for those platforms that use it) * Handle allocation failure in json_tokener_new_ex * Fix use-after-free in json_tokener_new_ex() in the event of printbuf_new() returning NULL * printbuf_memset(): set gaps to zero - areas within the print buffer which have not been initialized by using printbuf_memset * printbuf: return -1 on invalid arguments (len < 0 or total buffer > INT_MAX) * sprintbuf(): propagate printbuf_memappend errors back to the caller Optimizations -------------- * Speed up parsing by replacing ctype functions with simplified, faster non-locale-sensitive ones in json_tokener and json_object_to_json_string. * Neither vertical tab nor formfeed are considered whitespace per the JSON spec * json_object: speed up creation of objects, calloc() -> malloc() + set fields * Avoid needless extra strlen() call in json_c_shallow_copy_default() and json_object_equal() when the object is known to be a json_type_string. Other changes ------------- * Validate size arguments in arraylist functions. * Use getrandom() if available; with GRND_NONBLOCK to allow use of json-c very early during boot, such as part of cryptsetup. * Use arc4random() if it's available. * random_seed: on error, continue to next method instead of exiting the process * Close file when unable to read from /dev/urandom in get_dev_random_seed() Signed-off-by: Nick Hainke <vincent@systemli.org>
Diffstat (limited to 'package/libs/libjson-c/Makefile')
-rw-r--r--package/libs/libjson-c/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/libs/libjson-c/Makefile b/package/libs/libjson-c/Makefile
index 0f13883a3b..2b90c27a4a 100644
--- a/package/libs/libjson-c/Makefile
+++ b/package/libs/libjson-c/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=json-c
-PKG_VERSION:=0.15
-PKG_RELEASE:=2
+PKG_VERSION:=0.16
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-nodoc.tar.gz
PKG_SOURCE_URL:=https://s3.amazonaws.com/json-c_releases/releases/
-PKG_HASH:=99bca4f944b8ced8ae0bbc6310d6a3528ca715e69541793a1ef51f8c5b4b0878
+PKG_HASH:=ac8a3dd6820daaca579b23fbc74664310fbc3d67f52f6707cda67d21dde5570f
PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
PKG_LICENSE:=MIT